舧ㄏノ

???? to SpectraPLUS-SC

S pectraPLUS-SC i??????????????? ???????? Windows ??????????????????????????????????�??????????. ???????�????????FFT size ??????????????????????????????????????????????????????????????3-D ?????????/ ?????????????�??????????CPU??????????????.

???: Basic Operation, What is a Spectrum Analyzer


繵眯だ猂祸琌ぐ或

????????

?????????????????????????????? - ???????????????????????????"????"????????????????????????????????????????????????????????????????????????????????????????????audio band.?????????????????????????????

????????

????????????????????????????????????????????????????? .

????

????????????????? ????????Lin e-In ?????????? SpectraPLUS-SC?????????????"??-??"?????????????????CPU??????????FFT????????????????

See also: Application Notes , Performance Issues


╰参惠―

????

Current ???????:

150 MHz Pe ntium CPU ??

128 MB RAM ??, 20 MB ??????

256 color VGA ????? (1024 x 768 ??)

Windows ??????

?????????


膀セ巨

????

????????????????????? ?

????

Real-Time{linkID=40} ??????????????????????????????????????60????????????????????????????Recorder ?Post- Processing ?????????????????wave ??

  • Recorder ??????WAV ???????????????????????????????????????
  • Post-Processing ???????????????????WAV???????Real- Time ?Recorder ????????????????????????????overlap processing {?linkID=390}???Spectrogram {?linkID=160}?3-D??{?lin kID=180}????????????.
  • ??
  • Time Series ????????????????????? (????????).
  • Spectrum ????????????????????
  • Phase ?????????????????.
  • Spectrogram ?????????????????????????????????
  • 3-D Surface ????????????????
  • See also: Setting up the Analyzer


だ猂祸砞﹚

??????

????:

????????? (???????????) ?????????????????????????.

????:

?????????????????????????????, <Options> ??????? <Settings> ?? ? Settings ?????????? Sampling Rate{linkID=190} ?????????????????? FFT size{linkID=290} ???????????? (??????) ???OK ??????.

????:

?, <Options> ??????? <Scaling> ???? Scaling ?????????????????????????????????? .

????????????

???????????????????????????????????????????????? 3-D Surface ? Spectrogram{linkID=160} ??????????? ???????????.

??????

????????????????????????e Recorder??????????????????????????? Real-T ime ?????????????????????????????????????????WAV ??.

?????

??????? <Run> ? <Rec> ???????? <al t> <R>???????????????????????. enter??????????????.

?????????

??????? <Stop> ???????? <alt> <S> ???????????????????????????????????. (??? Cursor Measurements ).

????

??????? <File> <Print> ???????????????????????????????????. .

????

???????<File> <Load>?????????????????????????????? WAV??????????.

???: Bas ic Operation, What is a Spectrum AnalyzerlinkID=20} , Working With Audio files , Aliasing,{linkID=790} Printing , Config uration Files{linkID=960} , Keyboard Shortcuts


ㄏノ村夹ㄓ秖代

???????

????:

??????????????????????X ?Y ????????????????.

Control Key + ????:

?????????Ctrl ????????????????????????X?Y?????????????????????????????????

Shift Key + ????:

????????? Shift ??????????????????????????10??????????????????????????? .

Control + Shift Key + ????:

????????? Control ? Shift ??????????????? "sideband cursors". ???????????????????????????????????????????????.

????:

????????????????????????????????????????????????? Right Click Acti on Menu .

?????????????? "pull" ?? ???? spectrum/phase display options{linkID=110} ?????????.

??:

?????? "Stop" ????????????????????.

3-D ??? 3-D Surface ????????????? (X-?) ???????????????????????????????????.

???: Keyboard Shortcuts, Toolbar{linkID=9 40}


菲公龄┰Α睲虫

??????????

????????????????????????????????????????????????????????????????????? "cross display" ??.

????

Select All - ??????????.

Cut - cuts ???????? .WAV??? ?????.

Copy As Wa ve - copies{li nkID=770} ???????? .WAV??????????.

Copy As Text - copies{linkID=770} ??????????tab?? ?????.

Copy as Bitmap - ??? bitmap ????????????.

Save To Wave File - ?????????????? (????????????)

Mute - mutes ???????.

Filter - filters ?????????.

Play - ??????? output device{linkID=410}.???????.

Autoscale Display - ?????????? Plot Top/Range ????.

Pull Cursor To Tr ace - ????????, ???? measurement cursor{linkID=870} ??????????? "pull" ??t.

Compute and Display Averag e Spectrum - ?????averaging.??????????????????????? .

Compute and Display Spectrogram - ????FFT?? FFT size ??? averaging{linkID=270} ?? ?????????????. o verlap percentage ?????????????????????????.

Compute and Display 3-D Surface - ????????? ??? 3-D ? ??Surface view for the selected time segment ????? FFT size{linkID=290} ? averaging ????????????? ove rlap per centage{linkID=390} ?? 3-D Su rface ???????.

Compute and Display RT-60 - ??? ??????????. Click here for more details

Perform DTMF Analysis - ?????? DTMF ????.

Compute RMS Level - ?????????? RMS ??.

Compute Crest Factor - ???????? crest factor.

Compute Envelope Usin g Hilber t Transform - ??????Hilbe rt Transform.????????? Envelope (magnitu de) ???????????? "zoom out full" ????????????.

Compute Schroeder Integration - ??????M. R. Schroeder's method ??(????)???????????????? "zoom out ful l" ????????????.

View Data Values - ???????????????????????????????.

Properties - ?????????.

Help - ??????.

????

Copy as Text - ??????????????????.

Write to Text File - ???????????ASCII ?????.

Copy as Bitmap - ??????bitmap ????????.

Clear Spectrum - ??????????????/ ??????????

Clear Peak Hold - ??????????????/ ????????????????.

Autoscale Specctrum - ????Plot Top/Range ??????????.

Pull Cursor To Trace - If ????????? measurement cursor ?????????? "pull"????.

Inverse FFT - ????? FFT{linkID=420} ???? time series view.????

Compute Cepstrum - ???????????FFT .

Bandwidth and Q Factor - ?????????????? half power bandw idth ? Quality Factor ????.

Set Marker N - ????????????? marker N .

Clear Marker N - ???????

Marker Options - ?????????

Smooth Spectrum N - ?N??????????? (???? ?????????).

View Data Values - ????????????????????????????? .

Propertie s - ?????????.

Help - ??????.

????

Copy as Text - ????????????????????.

Copy a s Bitmap - ???????bi t map ???????.

Pull Cursor To Trace - ???????, measurement cursor{linkID=870}?????????? "pull"????. .

View Data Values - ?????????????????????????????.

Properties - ?????????.

Help - ??????.

3-D ???

Cut - ??cuts ?????? .WAV????????.

Copy as Wave - ??copies ?????? .WAV????????.

Copy as Bitmap - ?????bitmap ???????.

Mute - mutes ???????.

Filter - filters ????????.

Play - ?????????o utput device{linkID=410}.??????.

Autoscale 3-D Surface - ????Plot Top/Range ??????????.

Dis play Time Series - ?????????????????????????.

Compute and Display Average Spectrum -?????? averaging. ?????????????????????????.

Compute and Display Spectrogram - ?????FFT size{linkID=290} ? averaging{l inkID=270}???????????????? spectrogram .????????????? overlap percentage{linkID=390} ????????????.

Expand 3-D Surface - ???????????????? 3-D ??????????? An overlap perce ntage{linkID=390}3-D??????????.

Properties - ?????????.

Help - ??????.

???

Cut - ??cuts ?????? .WAV ???????.

Copy as Wave -?? copies ?????? .WAV ???????.

Co py as Bitmap - ???????b itma p ???????.

Mute - mutes{linkID=1180} ???????.

Filter - filters{lin kID=78 0} ????????.

Play - ?????????output device{linkID=410}.??????.

Autoscale Spectrogram - ????Plot Top/Ran ge ??????????.

Display Time Series - ?????????????????????????.

Compute and Display Average Spectrum - ?????? averaging{linkID=270}. ?????????????????????????.

Expand Spectrogram - ?????????????????????? An overlap percentage??????????.

Compute and Display 3-D Surface - ????? FFT size ? averaging{linkID=270} ?????? ??????? 3 -D ??????????? An overlap percentage3-D??????????.

Properties - ?????????.

Help - ??????

???: Spec trum View{linkID =130}, Ti me Series View, Phase View{linkID= 100}, Spect rogram View{linkID=160}, 3-D Surface View


挡狦

????

????????????????????????????????????????????????????<File> ?????? <Print> ????????????? OK???

<File><Print Setup>?????????????????.

Annotation: ?????????????????????????. .

Margins: ????.

Comments: ???????????10?????.

??:

?????????????? spectrogram , ?????????????? ?????????????.

????????3-D??? 3-D surface , ?3-D????????????????????.

  • ?????????.
  • ????3-D ?????????
  • ???: Configuration Files


矪瞶贺羘郎

???????

? Open/Save/SaveAs ????????????????????? .WAV ????????File Import?? import????????????????? , ??????W indows File Manager? "Drag and Drop" (?? Winfile.hlp).

???????, ????? recording ??????? sampling rate{linkID=190} ? format{linkID=200} ?????????? .WAV ?????????????????????????.

???????? Real-Time,{linkI D=410} ????????????????????????????.

??????????????????????????????Mono ???????? (???????? * 2 ):

Sampling Rate (Hz) Sampling Precision (bits) Bytes/Minute

11,025 8 661,500

11,025 16 1,323,000

22,050 8 1,323,000

22,050 16 2,646,000

44,100 8 2,646,000

44,100 16 5,292,000

44,100 24 7,938,000

96,000 16 11,520,000

96,000 24 17,280,000

??????Continuous Recording Capability

?????????????? 2 GB (????????????)????????????????????????????????????????????????????????????? <File><Set Paths>?????????? \wave ????? ???????????????

?: c:\speclab\wave\recording_2002_11_2 6_102011.wav

(?? ???????? 10:20:11 Nov, 26 2002 )

???: Recorder Mode , Importing Files, Exporting Files, Cut/Copy/Paste commands{li nkID=770}


郎块

????

??? .WAV ???? binary?????????????? .WAV ??????????? sampling rate, ????????????Bit ?, ????????????. (L,R,L,R...).

?????????????????????????????.WAV ????????????????????? sampling rate ??? sampling format .

????:

ASCII Integer ASCII ?? - ????? text edi tor???????????????????????????????????????????????, ???

ASCII Fl oat ASCII ?? - ????? text editor???????????????? (e.g. 21.034). ??????????????????????????????????????????, ??? .

  • Binary 8 bit - 8 bit ??? .
  • Binary 16 bit - 16 bit ???.
  • Binary 32 bit - 32 bit ???.
  • Binary floating point - 32 bit ???.
  • ?????:
  • 8 bit WAV data: 0...255
  • 16 bit WAV data: -32767...+32767
  • 24 bit Wav data -8388607...++8388607
  • ??????:
  • '????????????? (ASCII ?) or ?2 ???? (binary file)??????. ???????????????.
  • ????:
  • ???? "rescale" , ????????????????????????????????? ?.

???? "tr un cate" ??????????????????????????.

  • ??????????? - ?????????????????????????????????.
  • ???: Wor king with audio f iles, Exporting Files,{linkID=830} Sampling Format,{linkID=200} Sampling Rate


郎块

????

????????????? .WAV ?. ???????????????????????

Decimation - ??????????? "do wn-sample" ?????.

??????:

ASCII Integer ASCII ?? - ????? text editor???????????????????????????????????????????????, ???

  • ASCII Float ASCII ?? - ????? text editor???????????????? (e.g. 21.034). ??????????????????????????????????????????, ??? .
  • Binary 8 bit - 8 bit ??? .
  • Binary 16 bit - 16 bit ???.
  • Binary 32 bit - 32 bit ???.
  • Binary floating point - 32 bit ???.
  • ?????:
  • 8 bit WAV data: 0...255
  • 16 bit WAV data: -32767...+32767
  • 24 bit WAV data: -8388607...+8388607
  • ??:
  • ????????????????????.
  • ???Binary ??????? text files???; ????????ASCII text??.
  • ????????? .WAV?????????????????????? <Edit> <Copy> ???????????????????????? <Edit> <Paste Insert>??????????????????? WAV ?.
  • ???? 16 bit WAV ?????? ASCII ? Binary 8 bit ?????? 8 bit ?.
  • ???: Working with audio files, Importing Files , Sampling Format, Cut/Copy/Paste Commands{linkID=770}


郎贺匡兜

???????

??? ? .WAV ??????.

????:

RAM - ???????????? RAM??.

  • ???? - ?????????????????????????????????? m egabytes ??? (???????????? 2 GB -?????????????? ).
  • ??:
  • ?????????????????????????????????????????????????? <File><Set Paths>??????????????????? . ??????????????????.

????????WAV ?

???????????????? WAV ?????????????????????????????????????????????. ?????????WAV ?????????????????????????????????????WAV ????????????????.

???????????WAV ?

??????????????????????????.

?????????Real Time Mode Data Buffering

?????????????????????????????????3-D?????????????????�??????????????????????

??????????????????WAV ???????????????????????????????????????????????????????60???????

??????Continuous Recording Capability

??????????????????????????????????????????????????????????????????? <File><Set Paths>??????. \wave ??????????????????.

?: c:\spe clab\wave\recording_2002_11_26_102011.wav

( ?????????? 10:20:11 Nov, 26 2002 )

??:

?????????? RAM ???????????????????? .

??????????????????(?????????). ??? Windows ????????????????????????????????????.

???: Working with audio files, Recorder Mode


搭秖妓

????

?????????? .WAV???????????sampling rate ??????????de cimation ratio???????????????????????????.

??:

??? a low-pass filter ?????.


郎ㄖ

????

????????? .WAV ?(mono) ???????????? (stereo) .WAV? ???????????????????????????

????????? .WAV ?????????????????? Merge ????????????????

???????????????sampling rates???? precision{linkID=200}.?


砞﹚隔畖

????

???????????????????????.


郎舱篈

????

????? <Config> ???????????????????????????????? ??????????????????,.

?????????????????????????????????????.CFG. ???WIN.INI ? SYSTEM.INI ????? ASCII ????

???: Working with audio files,


Cut/Copy/Paste 栋

Cut/Copy/Paste ???

Cut/Copy/Paste ??????????????????????????????????:

View Cut Copy Paste

Spectrum N/A ASCII table N/A

Phase N/A ASCII table N/A

Time Series .WAV format .WAV format .WAV format

Spectrogram .WAV format .WAV format .WAV format

3-D Surface .WAV format .WAV format .WAV format

??? Time Series, Spectrogram,{lin kID=160} ? 3-D Surface{l inkID=180} v??????????????????????????? toolbar.{linkID=940}???????. N?????????????????????????????? Edit ?? ???????? ?????????????????????real-time ?. ??????????.

????? .WAV ??????? .WAV ????.

ASCII ?????? 2 ??????????????????????????tab ??????????????? ????????? ?????????? overlay ? mic compensation{linkID=310} ??????.

<Undo> <Edit> ????????????????

??????: <Edit> <Cut, <Edit <Paste Over>, <Edit <Paste Insert> ? <Edit Filter> ??.

???: Working with audio files, too lbar{li nkID=940}


Play/Play Special 栋

Play/Play Special ???

??Play and Play Special ???????????????????????? .

???Time Series,{linkID=80}? Spectro gram,{linkID=160} ? 3-D Su rface{linkID=180}??????????????? toolbar.???????? ???????????????????????????????????????????? .

?<Edit> <Play> ??????????????????????????????????????????

<Edit> <Play Special> ??????4 ???:

Loop - ???????? (?? Stop ?????).

Half speed -???????1/2 ??????? .

Double speed - ???????2 ????????.

Arbitrary speed - ?????????????????

???: Working with audio files,{linkID=850} toolbar{linkID=940}


耾猧

??

???? .WAV ?????????????????? Time Series, Spectrogram, ? 3-D Surface ??????????????toolbar{linkID=940} ??????????????????? ??????? ??????????????????????? toolbar??????????<Edit><Filter> ??. ?????????????????.

5 ??????:

Low Pa ss - ????????????????????????? .

High Pass - ??????????????????????????.

Band Pass - ????????????????????????

N ot ch - ?????????????????????????.

  • Custom - ?????????.
  • ?????Filter Sharpness - ???????????????????????????????????????????????????????????????????.
  • ?????Filter Gain - ???????????d B?????????????????????.
  • ?????????? :
  • ?? NOTEPAD.EXE ?????????????????????? ASCII ????.
  • ??2?????????????

?????????? Hertz.

?????????? decibels

?????????.

??tab ??????.

?:

---------------------------

100.0 -10.0

500.0 -5.0

1000.0 0.0

2000.0 2.0

10000.0 -5.0

15000.0 -15.0

????? 32,768 ??????????3 ????????????????????????????????????????????????????????????.FLT ????? .

  • ??:
  • ??????? Microphone Compensation ?,?? Overlay files ??????????????????????????????????????????????????????????? .
  • ? SpectraPLUS-SC ??? <File><Set Paths>????????????? ??????

???: Working with audio files, toolbar


繰

??�

??????????????0 .

??? .WAV???????????????? Time Series, Spectrogram, ?? 3-D Sur face{linkID=180} ?????????? to olbar{linkI D=940}?????.?????????????????????????????????? <Edit><Mute> ????????????????0? .

??:

?? <Edit><Undo Edit> ??????????????.

???: Working with audio files, toolbar{lin kID=940}


匡

??

?? Select All ?????????? time series{li nkID=80}, s pectrogram{li nkID=160} ? 3-D Surface{lin kID=180} ?????(??) ??????.

??:

??????? .WAV ??????? time seri es ???? Zoom Out Full ??????? the t ime series options{linkID=70} ?????.

maximum zo om limit .

???: Working with audio files{linkID=850}, toolbar{linkID=940}


糤痲秸俱

????

??? .WAV ????????????????? Time Series, Spectrogram , ? 3-D Surface ??????? vie w toolbar{linkID=940} ????????????????????????????? ?????????. <Edit><Gain Adjust> ???????????????(?) ??????? decibels (dB) ???OK ?????.

DC Offset?????

T???? .WAV???????( DC Offset )???????????? Time Series{linkID=80}, Spectrogram{li nkID=160}, ? 3-D Surfa ce{linkID=180} ?????? toolbar{linkID=940} ????????????????????????????? ?????????<Edit><DC Of fset> ?????? ?????????(?) DC Offset????? decibels (dB) ? ??Offset ???????????OK ?????.

??:

<Edit><Undo Edit> ????????????????.

???: Working with audio files, toolbar{linkID=940}


家Α

????

??????????????????? ?? FFT ????????? ??? ????????????????????????????????????????????????????????????????. averaging ? peak hold ?.

?????60????????????????????????Recording ???Proce ssing ????????????????WAV ?????.

????:

?? <Enter> ?????????? FFT ???????????????????????????????

????:

???????????????FFT???????????????????????CPU ????????????FFT ???????????????????????????????????????????????? post-processing{linkID=50} ??.

?????????????? ?????????????????????? Recorder{link ID=60} .

???: Basic Operation , Performance Issues , Settings


矪瞶家Α

?????

???????????????.WAV ???????????????????????????????? recorder , ?? Play/Play special ??????

?????????????? Recorder{linkID=60} ????? Real-Time{linkID=40} ?????????. ?????? ???????????? "st retch" ??? Spectrogram{linkID=16 0} ?3-D ??? 3-D Surface{linkID=180} ????????? overlap processing{linkID=390} ???????????????????????????????? real-time{link ID=40} ?????????

???? .WAV ?????? samplin g rate{linkID=190} ??? format{linkID=200} ?????????????? - ????.WAV ??????????????????????????

????:

?? <Enter> ???? (+) ??????????? FFT ?????????????????????????????

? ? (-) ??????????????????????????????? overlap percent {linkID=390} ??????.

?????????????????????????

???: Basic Operation{linkID=160} , Overlap Percentage,{linkID=180} Performance Issues{linkID=30} , Working with Audio Files{linkID=850}


魁诀家Α

?????

??????????????????"???" "Sound Recorder" ????????????????"???" "Sound Recorder" ????????????? sampling format ???? sampling rate. ??????????????????????.

???????? RAM file access{linkID=820} ???????????????????????????????????????????, File Options{linkI D=820} ????????.

??????? using the Hard Disk file access ?????????????????????????????????? <File><Set Paths> ???????????????????????????????????

??????????????????????????????????(??????by tes ?? ??2)?

???? (Hz) ???? (bits) Bytes/Minute

11,025 16 1,323,000

22,050 16 2,646,000

44,100 16 5,292,000

44,100 24 7,938,000

96,100 24 17,280,000

???? .WAV ?????? sampling rate ??? format ?????????????? - ????.WAV ?????????????????????? status bar ????

???????:

??????????? 2 GB ??? (????????????????)????????????????????????????????????????????????????? ?????????? <File><Set Paths> ?????????\wave ????. ?????????????.

?1: c:\spectr a\wave\recording_2002_11_26_102011.wav

(?????????????? 10:20:11 Nov, 26 2002 )

??:

????Windoes ??????????????????????????????? disk in tensive operations(?????????). ???????????????????????????????

???: Basic Operation , Sampling Rate, Device Options , Working with Audio Files


繵眯浪跌

????

????????????????Hertz (Hz)???????????????????? calibration ????.

???????????FFT ?? FFT size{linkID=290} / 2. ?????1024 bit ??? FFT,{linkID=420} ??? 512 ??????????0 Hz?????? Sampling Rate{linkI D=19 0} ?? Decimation Ratio.{linkID=250} ????

????????????????3?????????????DC ??????????1% ?????????alias{lin kID=790} ????????.

??????????The zoom buttons toolbar ???????????????????????? FFT ?????????????.

????????????????????????? <Edit><Copy>????????????????????????????????????????

Toolbar Controls

Spectrum Display Options{linkID=110}

Spectral Overlays

Cursor Measurements

Right Click Action Menus{linkID=860}

???: Scaling , Measurement Accuracy , Performance Issues{l inkID=800}


浪跌

????

?????????/ ?????????????/ ????????????????????? "stereo" ????? "Transfer Function" ???

?????????? sca ling ??????? ?? toolbar{linkID=940} ???? zoom ??????????????????.

?????????????????????????? <Edit><Copy> ??????????????????????????????????txt ???

???? smoothing window. ???????? ?? "Uniform" ??????????????.

Toolbar Controls

Phase Display Options

Cursor Measurements{linkID=870}

Right Click Action Menus

???: Scaling{linkID=360} , Measurement Accurac y , P erformance Issues


繵眯瓜浪跌

?????

???spectrogram???????????????????????????????????????????????????????????????????????????3-D ????????color bar ??????/ ?????? .

????spectrogram??????????????????????????

Toolbar Controls

Spectrogram Display Options

Cursor Measurements

Right Click Action Menus{lin kID=860}

???: Scaling{linkID=360} , Measurement Accuracy{linkID=800}


3-D 瓜浪跌

3-D ?????

?????????????????X ?????Y ?????????????????????????

???????????????????(?????)????????????

Toolbar Controls

3-D Surface Display Options

Cursor Measureme nts

Right Click Action Menus

???o: Scaling , Measurement Accuracy


砞﹚

??

?? Options | Processing Settings ???????? Settings ????? FFT ????????????????:

Sampling Rate

Deci mation Ratio{l inkID=250}

F FT Size

Smoothing Windows{linkID=280}

Sampling Format{linkID=200}

Av eraging Settings

Peak Hold

Overlap Percentage

Dual Channel Processing Options{linkID=230}

Cross Channel Delay

Overload Detection{linkID=210}


へ夹

??

?? Options | Processing Settings ???????? Scaling ???????????? .

????????????????? ?????? Time Series ?Y ?????? Phase{linkID=1 00}?????????: .

Amplitude Axis Scalin g{lin kID=330}

Frequency Axis Scaling{lin kID=340}

Power Spectral Density (PSD{linkID=350})

Standard Frequency Weighting{linkID=300}

Microphone Compensa tion{linkID=310}

???????

??Settings {l inkID=240}?????? "????????" ?????????????????????????????????????????????????????????????????????????G ??????????????1/3 octave ????????????

???: Measurement Accuracy{linkID=800} Dual Channel Processing{linkID=230}


夹癘

??

?????????????????.

???????????? "Mrk" ? ???? marker ???????.

????????? markers. ???????????????30????

???????????????????????markers??????? Right Click Action Menu{linkID=860}. ?????? "Set Marker #" ?????????????????????"Clear All Markers" ?????????????????????<Op tions><Markers> ????????


牟祇

??

?? Options | Processing Settings ???????? Triggering ??????? trigger??????.

???????????????FFT FFT. ??????????

Trigger M ode: ????????????:

Rearm and wait for next trigger - ???????????????????????????????

  • Stop the analyzer - ???????????????????????.
  • Continue running or recording -???????????????????????????????????????????????????.
  • ????Trigger Channel: ??????????.
  • ????Trigger Type:
  • Level triggering - ???????????????????????????
  • Edge triggering - ???????(???????????????)?????????????? . ???????????.

?????Trigger Polarity: ????????/ ?????.

??Threshold: ?????????????.

  • Trigger Delay/Type: ????FFT ????????Pre-delay ?????????, post-delay ??????. ? delay ??0 ???????FFT ????????.
  • Start signal generator on initial trigger event - ??????signal genera tor{linkID=620} ???????????????????????????????????????? ????????????????????????????.

??:

????????????????????????????????????????????????????????????.

??!

????????????????????????????? status bar{linkID=910} ????????????.


タ

??

?? Options | Processing Settings ???????? Calibration ????????????.

??????????????????0 dB ???????????8, 16 ? 24 bit ???????????????????????.

??????????????????????????????????????????????????????.

?? <Options><Calibration> ???????????? .

????:

??????????????????? (???? DC level ????? ).

?edit control?????? (????????????????????).

????????????: "Peak", "RMS" ?"Peak to Peak" (?. ????? R MS ?).

  • ????????????????? .
  • ?????????: "Peak", "RMS" ? "Peak to Peak".
  • ?? "Measure Input Signal" ??????????1 ????????????????????.
  • ????????????????????G (ft/sec^2)??? "Convert Spectrum To:" ??????????????????????????????? .
  • ?????? edit box????.
  • ???? "Enable Calibration" ???????????????????????????????.
  • ??????????????????.
  • ??: "Measure from Wave File" ?????????????? WAV ?? ????????????????????????????????????.

???????

??Settings {linkID=240} ????? "Independent Scaling and Calibration" ????????????????????????????????????????????????????????????????G ?????? ????????1/3 octave ??????????.

????!

???????????????????????????????????????????.

???: Scaling,{linkID=360} Microphone Compensation{linkID=310} Sett ings{linkID=240}, Scaling{linkID=360}, Dual Channel Processing{linkID=230}


笲︽北

????

?? Options | Processing Settings ???????? Run Control ?????? "Run Ctrl" ?????.

????The Run Control ???????????????.

?? <Options><Processing Settings> ?????(?? F4) ???? "Run Control" ?? ???????????????? "Run Ctrl" ???????????.

Run continuously until Stop button is pressed: ?????????? ??????????????????

Stop after N FFT's have been processed: ???????FFT ??????????.

Stop after N seconds of data have been processed: ???????????????????.

Delay processing until N seconds have elapsed: ????????????????????????.

Analyzer Update Interval: ????FFT ????????? "slow down"?????????????????????????????.????????????Post Processing??? .


砞称贺匡兜

???????

?? Options | Processing Settings ???????? I/O Device ????? I/O ??????.

???????????? ?????????????????????? sampling rate{linkID=190} ????

?????????The Intput Device?? ??? Recordin g ??????? Real Time , ???? The Output Device???????? .WAV ?????????? Signal Generator ???

????/ ????Adjust Input/Output gain -????????????????????????MIC ???? ??????????/ ????????????????? gain/volume ????

???????

??????????? :

Standard Windows Multimedia Driver (MME) - ??Windows ????????????????????? ????????????????????????????????????????????????????.

Audio Stream Inpu t Output (ASIO) - ?????Steinberg Media Technologies GmbH????????????? ??????????????????????????????????????????"????" ????????????ASIO??? ??

??: ??? ASIO ???????????????????????


癟腹玻ネ竟

?????

?? <Utilities><Signal Generator> ??????????F11 ?????????????????Windows ????????(D/A) ???????????????.

????

??????????????????.

?? "Details" ???????????????.

?? "Level" ????????? generator output level{linkID=600}.

  • ?? "Run"???????? .
  • ???????????????????? "Stop" ??.
  • ????
  • White Noi se
  • Pink Noise{linkID=570}
  • Noise Burst{linkID=560}
  • 1 kHz Tone{linkID=540}
  • Multiple Tones{linkID=530}
  • Tone B urst{linkI D=550}

IMD Test Tones{linkID=520}

Frequency Sweep{linkID=510}

Frequency Step{linkID=515}

Level Sweep{linkID=500}

Sawtooth{linkID=490}

Triangular{linkID=480}

Pulse{linkID=470}

Square{linkID=460}

User Defined{linkID=450}

DTMF{linkID=580}

Digital Zero{linkID=610}

?????

??????????????????????????????????????????????????"AC??"????????????????????

??????????

??????????????????????????????.

???: Generator O utput Level{linkID=600}, Device Options{linkID=410}, Save Signal To Wave File,{linkID=440}


р癟腹纗WAV 郎

??????WAV ?

????????????? .WAV ???????????????????????

??????????????????????????? ????? .

???: Signal Generator, User Defined Waveform


畃繵瞯

????

??????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????.

??:

??????????????spectrum view. ???.


畃碩

????

??????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????.

??:

?????????????????.


羆

???

??????????????????????????RMS?????????????????????????A???B???C????????????SPL??????????

????????????????????????????????????????????????????????????????????????????????????????.

??:

?????????????????.


羆坑猧ア痷

?????

?????????????????????????????????????? Total Harmonic Distortion (THD) ? (THD+Noise) ???????????????????????????THD ????????"??"?

Total Harmonic Distortion (THD) -?????????????????????????(??)????????????????????????????THD ????????????.

Total Harmonic Distortion + Noise (THD+N) - ?????????????????????????????(??)??????????(?? + ??)???????????+?????????THD ???? .

?????????THD+N ?????? THD ??.

???THD ????? 1kHz ??????. ????????????????????????? averaging?????????????????.

?????????????????????????????????????????? signal generator ???????????????THD???.

????????????????????????????????????????????????????????????????????????????????????????

??:

??Hanning ? Blackman smoothi ng window ?????????????????.

??? FFT FFT{linkID=420} size ? 2048 ???????????????.

?????????????????.

???: Measurement Accuracy{linkID=800} , Application Notes - Total Harmonic Distortion,, THD+N vs Frequency


THD+N癸繵瞯羆坑猧ア痷馒癟

THD+N ????????????

THD+N????????????T THD+N ?? ????????????????? THD+N ? ????????????????????????????????.

??<Utilities><THD+N vs Frequency> ???????? "THD Freq" ?????????????????????????????????????????????????????????????????????????????????????????? .

???????????????????????????????????????????????????????

??

???????"Options" ?????? THD+N ?????????????????????????????????????????? :

Start and Stop Frequencies - ?????????????????????????????? 1/2 .

Channels - ?????????????.

Signal Output Level - ?????????dB ???????? 100% ?????????? 0.0 dB????????????????????????????????????? "full scale" ?????????? ".

Frequency Step size -?Hz ?????/ ??????(1/1 thru 1/96)??????????? (1/1 thru 1/96). ???????1~2??????????????????

Spectral Weighting - sets??????????? spectral weighting .

Plot Top - ?????????????????????.

Plot Bottom - ????????????????????? .

Frequency Axis Scaling - ??????????.

Amplitude Axis Scaling - ??????????.

Test Limits - ??????????????????????????? ?????????overlay ????mic ?????????????ASCII ????????????????THD ??? ? ?????????? .

Prompt to Save - ????????????????.

??:

a) ?????????????????.

b) ???????????????:

Device selection

Sampling Rate

Sampling Pre cision


が秸ア痷 (IMD)

???? (IM D)

???? (IMD)???????????(??)?????.

?????????????????????????IMD ?????????????????????????????????????????? IMD???????????RMS ???????.

??? IMD ????250 Hz ? 8020 Hz???????????? 12dB (4:1 ratio)????? averaging?????????????????.

????????????????????????????????????????????????????????????????????????????????????????.

.

??:

??Hanning ? Blackman smoothing window{linkID=280} ?????????????????.

??? FFT FFT{linkID=420} size ? 2048 ???????????????.

?????????????????.

???: IMD test tones{linkID=520}


癟腹馒癟ゑ (SNR)

????? (SNR)

?????Signal to Noise Ratio (SNR) ?????????????????? decibels (dB)??.

????????????????????????????????????????????????????????.

????????????????????????????????????????????????????????????????????????????????????????.

.

??:

??Hanning ? Blackman smoothing window ?????????????????.

??? FFT FFT size ? 2048 ???????????????.

?????????????????.

???: SINAD{linkID=6 80}, NF{linkID=670}


獺靖㎝ア痷 (SINAD)

????? (SIN AD)

SINAD ?????FM????????????????????( acronym)????SIgnal , ??Noise, And ??Distortion ??????( acronym)??????????S + N?/ N?????????dB?????????????SINAD?????SNR????SINAD???????.

????????????????????????????????????????????????????????????????????????????????????????.

??:

??Hanning ? Blackman ?????????????????.

??? FFT size ? 2048 ???????????????.

?????????????????.

???: SNR, NF


馒癟计 (NF)

???? (NF)

????Noise Figure (NF) ?????-?????????dB ??.

???? Noise Figure????????????????????????????????????????????????????SNR????????????????0 dB????????????????? 0 .

??1 K Hz ????????????????????"???"????"???"???????????????????"???" ???????????? .

??????? <Options><Settings> ???????(Stereo ) ????????.

??????????????????????????????????? .

??:

??Hanning ? Blackman ?????????????????.

??? FFT size ? 2048 ???????????????.

?????????????????.

???: SNR, SINAD


┑筐 穓

????

?????????????????????????????ms?????????????"Apply to Processing Delay"????????????????????"????????" cross channel processing delay. ????????? <Options><Settings{linkID=240}> ???????.

????????????????.

?????????????????.

????????????????????????.

??

???????????? "Options" ???????????:

Display Delay Values In: - ?????????? milliseconds, feet ? meters???

Speed of Sound - The????????ms ????? feet ? meters????????????????????? ??????????????????????? 1130 ft/sec -?????????.

???????????????ms??????(T1) ??????????????????????(T2) ???????:

Speed of Sound (ft/sec) = 1000 / (T2 - T1)

Maximum Delay - This ?????????????????????????????.

?????

???????????.

??????????????.

??????????? pink{linkID=570} ???? white noise .

????????????.

????????????????? .

?? "Apply"????????????? processing setting.

??:

????????????Stereo ?????????Mono ???????? .

??????(???) ????????????????????????????????.


ミ砰陪ボ

??????

???????????????????????????????????; ???????/ ???? pan control?????????/ ??????????.

????:

???????????????????:

?? <Options> <Phase Scope Display> ?????.

???????????.

?????????????????? <Phase Scope Display Options> ?????.

  • ??: ?????????????????? ?? "Default" ???????????.
  • ??: ???? ????????:
  • ?????Stereo Image Scope - ??????????????45 � ????????????.

?????Lissajous (X/Y) Left vs Right -??????????X/Y ???????????????????? .

?????Lissajous (Y/X) Right vs Left - ??????????X/Y ????????????????????.


睼臫丁

????

???????????????????????????????????????????????????????????????RT-60 ????????????????????????60dB ???????.

???????????????????????RT-60?????????????????????????????????????????????????????????????????"??"???????????????????RT-60????????????????????????????????

??????????????????????????????????????????????????????????????( ????????????)????????????????????.

??????????(????????)???????????? :

1) ???????????????????.

2) ????????????????????????????????????????????????????????????? .

3) ??????????????????????"Compute and Display RT-60" ?.

4)?????????????????? .

5) ??????????????????Start Offset ??????????????????????????? "Set Decay Start Time" ????????????????????????????????????????????..

???????????????????????????????? ????????????????????????????????????????????

????????

Reverb Times - ?????????????????????80 Hz?20 kHz?1/3????????"??"?????????????????????RT-60??????????????RT-10 ??????????????????????????.

Reverb Decay - ????????????????????????????????????????????????????????.

3-D Surface - ???????3-D?????????????????????????????????????????????????????????????????.

???????

???????? "Options"????????????? ????????????????????????:

??????Maximum Decay Time -???????? "listen" ???????????????????????????? (?????????????). ????????????????????????????????????.

?????????Decay Start Time Offset - ???????????????????????????????100??(100 ms) ??????????????????????????????????????????????????. "Set Decay Start Time" ???????. ???????????????? "Clear Decay Start Time Offset" ??????.

Clear offset when test is run or file is loaded - ????????????????????????????????0?.

???Extrapolation Method - ???????????????????????????60dB???????????????????????RT-60?????????RT-10?RT-20??RT-30?????? ???RT-20???????????????????????

????Smoothing Method -???????????????????????????????????????????????????????????????????????"None" ???????? "Average"? 100 ??ms???????????????? "Schroeder" ????RT-60????????????????????????????????? "Average"???????????????????????.

????Plot Colors - ??????

????Plot Top - ????????3-D ??????????

????Plot Range - this ????????3-D ???????????.

??????Typical Reverberation Times - ???????????????RT-60 ??.

??:

???????????????????????? 0 dB.???????????????????????????????????????????????.

??????????10 ???????????????????????.


单靖贺夹

?????????

?????????? Leq ??????????????????.

Leq(t) - ??????"??????"?????????. ?????3.6 ????90 dBA ?????????1 ?? (3600 sec)??????????? 60 dBA.

Leq - ???????????.

Lsel - ???1 ??????????.

Lpk - ?????????. ????????????.

Lmax - ?????????.

Lmin - ?????????.

L10 -???? 10% ???.

L50 - ???? 50% ???.

L90 - ???? 90% ???.

?? "Options" ??????????????????????????

Calculation Interval: ?? ?????????????.

Specific Intervals: Leq ?????????????.

When the Analyzer Stops: ??????"Stop"?????????????Leq ???????????????????. (??????????????).

??:

??????????(??????)? Leq and LeqT ??????? ? Leq?????????? LeqT ???????. Leq ?????????????Run ????? Stop??????????????? LeqT ?????60????????????60 ?, Leq ? LeqT ????? (?????). ??????????????????????? Leq ???????.????????????4 ?????60?????? LeqT ? Leq ?????.

????????????????????????? .

???: Right Click Action Menus{linkID=860}, Averaging Types{linkID=270},


甭舦

??

?????????????:

"Software Key" ? hard drive * 1

  • "Hardware Key" ?? USB Parallel Port *1
  • "Network Hardware Key" ??????????? *1
  • ???<License><Status and Authorization> ?????? ?????????????????????????????. ???????????Software Key ??????????????????????????????????????;.

??????

????? "Site Code" ? "Authorization Key" ?????????????????.

?? "Site Code"??????????????????????????? Sit e Code ????????????Site Code?????????"Authorization Key" ???? <License><Status and Authorization>???????? "Authorize"??? .

?? "Authorize" ???????????? "Site Code" ??? "Print Site Code" ???????sie bode ??????????????authorization key ??????????enter?????? Site Code ??????.

??????????

????????????????????????????????????? ??? "Site Code"??????? "Authorization Key"? ?? <License><Status & Authorization> ?????? "Authorize" ??????? Authorization Key; ??????????????.

???????????

????????? <License><Status & Authorization> ?????? "Transfe r Key" ???????????????????????: 1) ???????????? 2) ??????? USB???? ?????????????????????SpectraPLUS-SC ?????????2????????USB ????"??"??SpectraPLUS-SC????????????Software Key????????SpectraPLUS-SC??????copy ??????????

???????????????????????????????????????????????????????????? ???????????.

?????

????????"dongle"????????????????????????????

??????? USB ??????.

??????????????.

???????????? CD-ROM. ???????????????????????????.

????????

???????????????????????????????: ?????? "Field Activation Key"? ?? <License><Status & Authorization> ?????? "Authorize" ??????? Authorization Key; ??????????????

???????

???????? USB ????????????????????????????"?????" Network Hardware Key ????????????????? ??????????????????????????? ??????????? ?????????SpectraPLUS-SC????????????????????????????????5 ????????????

??????????????????????????? "License Server" ???????? "License Server" ?????????????????????????????? SpectraPLUS-SC ???????

??????????SpectraPLUS-SC ??.

  • ????????? "license server".??????????? Network Hardware Key installed.
  • ?? "license server" ?????? "server" ?????? peer to peer????????.
  • ?? "license server" ????????????.

??"Automatically find the license server on the network" ????????????????????????????.

??????????????????????????.


戈癘魁

????

????Data logging??????????????????????????????????????.

??

Enable Logging: ?????????.

Filename Format: ????????????????????????????

Overwrite Existing file: ??????????????.

Append to Existing file: ??????????????????????. .

Include Time Stamp in first column: ????????????????????.

Include Header on first row: ??????????????????.

Viewer Program: ??????????????????????????? ASCII??????????.

??????????

Output D ata Type: ?????????????.

Logging Interval: ????????????????.

View Output File: ???????????????????.

View Data Logging Folder: ??Explorer??????????????????????? <File><Set Paths> ??????.

??: ?????????????????????????????????????????????.

????:

Data Logging On: Fri Sep 30 10:43:41 1995

?? ??(Hz) ??(dB)

--------------------------------------------------------------

10:43:41 527.56 -45.60

10:43:42 495.26 -54.03

10:43:43 495.26 -49.83

10:43:44 1399.66 -59.01

10:43:48 1399.66 -59.14

10:43:49 516.80 -56.38

10:43:50 549.10 -53.37

10:43:51 624.46 -43.66

10:43:52 559.86 -37.96


エ栋㏑矪瞶竟

???????

??????????????????????????????????????????????????? DDE (Dynamic Data Exchange) ???????????????????Vis aul Basic ???????????????????????????Visual Basic ???????????????. .

?????????????????????????ACCII ????????? 32KB.

Quick Run Buttons

??????????????6??????????????????????????.

?? ????:

1) Send - Send ??????? DDE commands; ???DDE ???????. ????????

Send [Run]

?? [Run] ??????.

2) Output - Output ?????? DDE request items; ???????????????. For example,

Output Peak Frequenc y

??????????????.

3) SetOutputFile - ?????????????????????????????????????????????. ,

SetOutputFile c:\temp\my_spectral_data.txt

?????????????If?????????????????, .

4) OutputComment - ???????????????????,

OutputComment Starting Data Collection

will??????? "Starting Data Collection" ????.

5) Wait - ???????????????????????????????????????:

WaitSeconds 4

???4 ????????????? ???????? 0.25 (250 milliseconds).

WaitTopOfMinute

??????????.

WaitTopOfHour

??????????.

WaitClock 1415

?????????? 1415 (14:15 or 2:15 PM). ??????0 ?? (0903)

WaitDate 12/04/2002

???? December 4, 2002. ??????0 .

????????????????????? WaitDate????? WaitClock? WaitSeconds.

WaitMessageBox text

?????????????????OK.

6) Loop, LoopEnd -????????????????? ,

Loop 10

Send [Run]

WaitSeconds 30

Output Spectrum

Send [Stop]

WaitSeconds 3600

LoopEnd

???????????????10?????????????30????????????????????????10?.

????????.

7) Label, GoTo, Return - ????????????????????????,

Label StartPoint

.

. ??????...

.

GoTo StartPoint

?????????????"StartPoint"???.

GoTo CollectData

Label CollectData

.

. ??????..

.

Return

Go To ????????? "CollectData"???? "Return" ??????? GoTo CollectData ????????????????. ??????10??????? (??)

8) ; - ???????????????????????????????.

9) AutoDateTime - ??????????????????????????????????.??????? Nov, 26 2002 10:20:11,

SetOutputFile c:\temp\SPL_data_AutoDateTime.txt

??????? c:\temp\SPL_data_2002_11_26_102011.txt

????????????? DDE ???? [File Save ] ?. ???????? (??. OutputComment Starting at AutoDateTime).

10) MacroEnd - ????????.

Other Notes:

??1??? ???????.

???????????????????????????????? SpectraPLUS-SC ?????????????????????????. c:\specplus\bin\specplus.exe c:\specplus\macro\MyTest.mac


笆篈计沮ユ传 (DDE)

?????? (DD E)

?Spectra PLUS-SC ??????????Dynamic Data Exchange (DDE) -??????????????????????????????????????????????????

??:

DDE ???????????????????????????Microsoft Visual Basic for App licatio ns (VBA) ????????????????????????????? . Note - Visual Basic (v5.0 and up) ????DDE ???Excel ????? VBA (Visual Basic for Applications).???

DDE ??????????? - Commands ? Data Requests.

Commands ?????????? "Run" ? "Stop" ???? SpectraPLUS-SC ?????.

Data Requests ?????????? "THD" ? "Spectrum" ???? SpectraPLUS-SC ????????????????.

??????DDE ????:

??"????"????SpectraPLUS-SC ????????????????????"advise"??????????????????<Paste Special>?<Paste><LINK>???????????????????Excel?????????????

??SpectraPLUS-SC. ?Spectrum View

??Spect raPLUS-SC <Edit><Copy> ?????

? Excel, ???????? <Edit><Paste Spe cial> ?????.

?? "Paste Link" ?? Ok.

?????? "DDE hot link" ???????????????????????????????????. .

???? DDE ???? :

?????"DDE conversation".?????SpectraPLUS-SC B???

????????????????DDE server and the topic. ???,

?????????????item ????S pectraPLUS-SC ????? Item ??????

DDE Server name:

"Specplus"

Topic names Supported:

"Data"

DDE Commands{linkID=1120}

DDE Data Request Items

Examples


DDE笆篈计沮ユ传 栋

DDE?????? ???

???????

[Run] ?????

[Run ##] ??????? ## ?FFT??????

[Single Step] ???? FFT ???.

[Go To ##] ??WAV?????? (## = ??) ???

[Go To Sample ##] ??WAV?????? (## =???) ???

[Stop] ?????

[Rewind] ??? WAV ????

[Fast Forward] ?? WAV ??????

[Record] ??????????? WAV ??

[Pause Recorder] ??????????????

[Resume Recorder] ?????????

[Play] ??????? WAV ?

[Play Segment $ &] ?? WAV ??? (#=?????, &=?????)

[Apply Filter # &] ?WAV ??????? (#=?????, &=?????)

[Set Filter Channel #] ????????? (0=? , 1=?, 2=???)

??

[Mode Real Time] ??????

[Mode Recorder] ???????

[Mode Post Processing] ???????

???????

[File Open FILENAME.WAV] ????? WAV ?

[File Open FILENAME.CFG] ????? configration ?

[File Open FILENAME.CAL] ????? calibration ?

[File Open FILENAME.MAC] ???????? macro ?.

[File Open FILENA ME.RVB] ????? th d vs frequency ?.

[File Open FILENAME.THD] ????? thd vs frequency ?.

[File Open FILENAME.FLT] ??????????????????

[File Save FILENAME.WAV] ????? WAV ????

[File Decimate FILENAME.WAV RATIO] ???????????WAV ?

[File Merge LEFT.WAV RIGHT.WAV] ??? mono WAV ????? Stereo WAV ?

[File Close] ?? .WAV ?

[File Delete #] ??????? ( - ????)

????????

[Cut Time Segment # &] ???????? (#=????, &=????)

[Copy Time Segment # &] ???????? (#=????, &=????)

[Paste Time Segment #] ???????? (#=????,)

[Mute Time Segment # &] ???? (#=????, &=????)

??

[Set Sampling Rate #] ????? # ??? Hertz

[Set Sampling Precision #] ?????? # ???????? bits ? (8, 16, or 24)

[Set FFT Size #] ?? FFT size

[Set Decimation Ratio #] ??????

[Set Channel #] ??????? # ?1???:

Left, Right, Both, Average, Coherence, Transfer LR,

Transfer RL, Transfer LR+C, Transfer RL+C

[Set Delay #] ???????? # ?????????

[Window #] ????????? # ?????? (?. Blackman, Flat Top, Hamming).

[Set Average Mode #] ???????? # ? Blocks ? Meter.

[Set Average Type #] ???????? # ?Exponential, Linear or Vector

[Set Average Size ##] ????????????.

?? Block ???? ## = 1...1000; 1001 = Infinite.

?? Meter ???? 0=Off, 1=Fast, 2=Medium, 3=Slow, 4=Forever

[Reset Average] ??????

[Reset Overload] ??????

[Set Peak Hold #] ???? # ?:

0=Off, 1=Fast, 2=Medium, 3=Slow, 4=Forever

[Set FFT Overlap ##] ?? FFT ????? (## = 0...99) ???????

??

[Set Amplitude Scaling Type #] ?????????? # ? Linear, Log or LogMag

[Set Left Amplitude Scaling Type #] ????????????? # ? Linear, Log or LogMag (independent channel scaling only)

[Set Right Amplitude Scaling Type #] ????????????? # ? Linear, Log or LogMag (independent channel scaling only)

[Set Frequency Scaling Type #] ?????????? # ? Linear, Log or Octave

[Set Left Frequency Scaling Type #] ????????????? # ? Linear, Log or Octave (independent channel scaling only)

[Set Right Frequency Scaling Type #] ????????????? # ? Linear, Log or Octave (independent channel scaling only)

[Set Octave #] ???????? # ? 1, 3, 6, 9, 12 etc.

[Set Left Octave #] ??????????? # ? 1, 3, 6, 9, 12 etc. (independent channel scaling only)

[Set Right Octave #] ??????????? # ? 1, 3, 6, 9, 12 etc. (independent channel scaling only)

[Set Spectrum Weighting #] ????????? # ? Flat, A, B or C

[Set Left Spectrum Weighting #] ???????????? # ? Flat, A, B or C (independent channel scaling only)

[Set Right Spectrum Weighting #] ???????????? # ? Flat, A, B or C (independent channel scaling only)

[Set Total Power Weighting #] ?????????? # ? Flat, A, B or C

[Set Left Total Power Weighting #] ????????????? # ? Flat, A, B or C (independent channel scaling only)

[Set Right Total Power Weighting #] ?????????????# ? Flat, A, B or C (independent channel scaling only)

[Set PSD Type #] ?? PSD ??? # ? 0 ? 1.

0 ? units^2/Hz

1? units/sqrt(Hz)

[Set Left PSD Type #] ????? PSD ??? # ? 0 ? 1. (independent channel scaling only)

0 ? units^2/Hz

1 ? units/sqrt(Hz)

[Set Right PSD Type #] ????? PSD ??? # ? 0 ? 1. (independent channel scaling only)

0 ? units^2/Hz

1 ? units/sqrt(Hz)

[Enable PSD] ?? PSD

[Enable Left PSD] ????? PSD (independent channel scaling only)

[Enable Right PSD] ????? PSD (independent channel scaling only)

[Disable PSD] ?? PSD

[Disable Left PSD] ????? PSD (independent channel scaling only)

[Disable Right PSD] ????? PSD for the right channel (independent channel scaling only)

[Set Mic Compensation File #] ????????????????

[Set Left Mic Compensation File #] ???????????????

[Set Right Mic Compensation File #] ???????????????

[Enable Mic Compensation] ???????

[Enable Left Mic Compensation] ??????????

[Enable Right Mic Compensation] ??????????

[Disable Mic Compensation] ???????

[Disable Left Mic Compensation] ??????????

[Disable Right Mic Compensation] ???????

?????

[Open Generator] ?????????

[Close Generator] ?????????

[Start Generator] ???????

[Stop Generator] ???????

[Set Generator Type Left #] ?????????????? XYZ ???????????????????????

? [Set Generator Type Left Pink Noise]

[Set Generator Type Right #] ?????????????? XYZ???????????????????????

? [Set Generator Type Right Pink Noise]

[Set Generator Tone Left Freq AmpDB] ?????????????? "multiple tones" ????????????????????

?????? 0.0 and -96 dB ??? [Set Generator Tone Left 1500 -24]

[Set Generator Tone Right Freq AmpDB] ?????????????? "multiple tones" ????????????????????

?????? 0.0 and -96 dB.??? [Set Generator Tone Right 1500 -24]

[Set Generator Wave File Left #] ??????????? "User Defined" ??? wave ?? (# = ??)

[Set Generator Wave File Right #] ??????????? "User Defined" ??? wave ?? (# = ??)

[Set Generator Level Left &] ?????????????? & ????.

[Set Generator Level Right &] ?????????????? & ????.

??

[Trigger] ????

[Trigger On] ?????

[Trigger Off] ?????

[Trigger ReArm On] ???????? ReArm.

[Trigger ReArm Off] ????????ReArm.

??

[Set Marker # xxx] ??????? # ? XXX Hz.

[Show Marker #] ???? #

[Hide Marker #] ???? #

??

[Set Overlay #] ??????????? ? # ????? (1-7)

[Set Left Overlay #] ???????????? # ????? (1-7)

[Set Right Overlay #] ???????????? # ????? (1-7)

[Set Overlay From Peak Hold #] ?????????????? ? # ????? (1-7)

[Set Left Overlay From Peak Hold #] ???????????????? # ????? (1-7)

[Set Right Overlay From Peak Hold #] ???????????????? # ????? (1-7)

[Show Overlay #] ??????? # ????? (1-7)

[Show Left Overlay #] ???????? # ????? (1-7)

[Show Right Overlay #] ???????? # ????? (1-7)

[Hide Overlay #] ???????? # ????? (1-7)

[Hide Left Overlay #] ????????? # ????? (1-7)

[Hide Right Overlay #] ????????? # ????? (1-7)

[Set Overlay Offset # &] ?????????? # ????? (1-7) & ? offset ? dB.

[Set Left Overlay Offset # &] ???????? ? # ????? (1-7) ? & ? offset in dB

[Set Right Overlay Offset # &] ?????????? # ???? (1-7) ? & ? offset in dB

[Set Overlay Legend # &] ?????????? # ???? (1-7) ? & ???

[Set Left Overlay Legend # &] ????????? # ???? (1-7) ? & ???

[Set Right Overlay Legend # &] ????????? # ???? (1-7) ? & ???

[Setup Composite Overlay # &] ???????????? # ????? (AVG or SUB)????AVG ?????????

??????: [Setup Composite Overlay AVG 1 0 0 1 0 0] ?????1?4???.

???SUB????????????? [Setup Composite Overlay SUB 4 6] will subtract overlay 4 from 6

[Setup Left Composite Overlay # &] ?????????

[Setup Right Composite Overlay # &] ?????????

[Save Left Overlay File # &] ??????? # ??????? &

[Save Right Overlay File # &] ???????? # ??????? &

[Load Left Overlay File # &] ???????? # ??????? &

[Load Right Overlay File # &] ???????? #??????? &

??

[Save Config #] ???????????.

[Load Config #] ???????????

??

[Calibrate] ??????????????????????.

[Save Calibration #] ???????????.

[Load Calibration #] ???????????

[Enable Calibration] ??????

[Disable Calibration] ??????

????

[Set Input Device #] ????????? # ?????????????

[Set Output Device #] ????????? # ?????????????

??

[Open Time Series] ??????

[Close Time Series] ??????

[Maximize Time Series] ??????????

[Restore Time Series] ????????????

[Set Time Segment # ##] ?????????????? # ????? ## ??????????

[Set Time Series Plot Top #] ????? Plot Top ???

[Set Time Series Plot Range #] ?? Plot Range ???

[Autoscale Time Series] ??????? plot top ? range

[Clear Spectrum] ????????

[Clear Peak Hold] ?????????

[Open Spectrum] ?? Spectrum ??

[Close Spectrum] ?? Spectrum ??

[Maximize Spectrum] ? Spectrum ?????

[Restore Spectrum] ?? Spectrumthe ???????

[Spectrum Freq Span # ##] ?? Spectrum ??????????? #????? ? ##????????? Hz

[Set Spectrum Plot Top #] ?? Plot Top ???

[Set Spectrum Plot Range #] ?? Plot Range ???parameter value

[Autoscale Spectrum] ??????? plot top? range

[Set Spectrum Bar Graph] ??????????

[Set Spectrum Stepped Bar Graph] ??????????

[Set Spectrum Line Graph] ??????????

[Compute Average Spectrum # ##] ????????????????? # ?????? ##??????????

[Compute Reverb # ##] ?????????????? (RT-60) ? # ?????? ## ??????????

[Open Phase] ?? Phase ??

[Close Phase] ?? Phase ??

[Maximize Phase] ?Phase ?????

[Restore Phase] ??Phase ???????

[Phase Freq Span # ##] ??Phase ??????????? # ?????? ## ????????? H z

[Open Surface] ?? Surface ??

[Close Surface] ?? Surface ??

[Maximize Surface] ?Su rface ???????

[Restore Surface] ??Surface ?????????

[Surface Freq Span # ##] ??3D Surface??????????? #????? ? ## ????????? Hz

[Build Surface # ##] ???????? Surface ??? # ?????? ## ??????????

[Open Spectrogram] ?? Spectrogr am ??

[Close Spectrogram] ?? Spectrogram ??

[Maximize Spectrogram] ?Spectrogram ???????

[Restore Spectrogram] ??Spectrogram ???????

[Spectrogram Freq Span # ##] ??Spectrogram ??????????? # ?????? ## ????????? Hz

[Build Spectrogram # ##] ?????????? Spectrogram ??? # ?????? ##??????????

[Copy to Clipboard as Bitmap] ?????? bitmap ????????

??

[Open Peak Freq Utility] ?? Peak Frequency ????

[Close Peak Freq Utility] ?? Peak Frequency ????

[Open Peak Amp Utility] ?? Peak Amplitude????

[Close Peak Amp Utility] ?? Peak Amplitude ????

[Open Total Power Utility] ?? Total Power ????

[Close Total Power Utility] ?? Total Power ????

[Open THD Utility] ?? THD ????

[Close THD Utility] ?? THD ????

[Open THD_N Utility] ?? THD+N ????

[Close THD_N Utility] ?? THD+N ????

[Open THDvsFreq] ?? THD+N vs Frequency ??

[Close THDvsFreq] ?? THD+N vs Frequency ??

[Start THDvsFreq] ?? THD+N vs Frequency ??t

[Save THDvsFreq #] ?? THD+N vs Frequency ????? # ???

[Print THDvsFreq] ?? THD+N vs Frequency ?

[Open IMD Utility] ?? IMD ????

[Close IMD Utility] ?? IMD ????

[Open SNR Utility] ?? SNR ????

[Close SNR Utility] ?? SNR ????

[Open DelayFinder] ?? Delay Finder ??

[Close DelayFinder] ?? Delay Finder ??

[Apply DelayFinder] ????? delay finder ?????? .

[Open PhaseScope] ?? Phase Scope ??

[Close PhaseScope] ?? Phase Scope ??

[Open Macro] ??macro ???????

[Close Macro] ?? macro ???????

[Open Macro File #] ??????? macro ??

[Start Macro] ????? macro

[Stop Macro] ????? macro

[Open Reverb] ?? Reverberation ??

[Close Reverb] ?? Reverberation ??

[Start Reverb] ?? Reverberation ??

[Save Reverb #] ? Reverberation ??????? # ???

[Set Reverb View Time] ?? Reverberation ??????????

[Set Reverb View Decay] ?? Reverberation ??????????

[Set Reverb View Surface] ?? Reverberation ????? 3-D Surface ?

[Enable DataLogging] ?? data logging

[Disable DataLogging] ?? data logging

[Set DataLogging File #] ?? data logging ???

[Open Leq] ?? Equivalent Noise ????

[Close Leq] ?? Equivalent Noise ????

[Reset Leq] ?? Equivalent Noise ?.

??

[Set Annotation Line1 XYZ] ??????????

[Set Annotation Line2 XYZ] ??????????

[Enable Comment Block] ??????

[Disable Comment Block] ?????????

[Set Comment Line1 abc] ??????????

[Set Comment Line2 abc] ??????????

[Set Comment Line3 abc] ??????????

[Set Comment Line4 abc] ??????????

[Set Comment Line5 abc] ??????????

[Set Comment Line6 abc] ??????????

[Set Comment Line7 abc] ??????????

[Set Comment Line8 abc] ??????????

[Set Comment Line9 abc] ??????????

[Set Comment Line1 0 abc] ??????????

[Print Time Series] ?? time series?.

[Print Spectrum] ?? spectrum ?.

[Print Phase] ?? phase ?.

[Print Spectrogram] ?? spectrogram ?.

[Print 3D Surface] ?? 3D surface ?.

[Print THDvsFreq] ?? THD+N vs Frequency?r

????

[Minimize Window] ???????????

[Restore Window] ????????????

[Maximize Window] ????????????

[Cascade Windows] ?????????

[Tile Windows Vertical] ????????

[Tile Windows Horizontal] ????????

[Hide Window] ????????

[Show Window] ??????

[Hide Menu] ???????????

[Show Menu] ??????????

[Hide Toolbar] ??????????

[Show Toolbar] ??????????

[Hide Toolbar2] ????????????

[Show Toolbar2] ????????????

[Hide Statusbar] ????????????

[Show Statusbar] ??????????????

[Hide Plot Toolbars] ????????????

[Show Plot Toolbars] ????????????

[Exit Application] ??????

????

[Ambient Compensate] ?????????????????1 ??????????

[Ambient Compensate Enable] ??????

[Ambient Compensate Disable] ??????

[Set Peak Search Bandwidth # &] ??????????????????

(# = ???? ? & = ????)

???: Dynamic Data Exchange{linkID=1150}, DDE Data Requests, DDE Examples


DDE笆篈计沮ユ传 戈璶―

DDE ?????? ?????

????

"Mod e" ???????: 1=Real time, 2=Post Processing, 3=Recorder

"FFT Size" ?? FFT ??

"Sampling Rate" ????????

"FFT Overlap" ??????? (0...99)

"Decimation Ratio" ????????

"Average Mode" ????????: 0=Free Run (blocks), 1=Sound Level Meter (SLM)

"Average Type" ????????: 0=Exponential, 1=Linear, 2=Vector.

"Average Size" ??????????/ ?? (1...1000; 1001 if infinite) (0=off, 1=Fast, 2=Med, 3=Slow, 4=Forever).

"Peak Hold" ???????? (0=off, 1=Fast, 2=Med, 3=Slow, 4=Forever)

"Smoothing Window" ???????????

?????

"Current Time" ????? WAV ??????

"Total Time" ?? WAV ????.

"Overload Status" ???? over load ??(1=tr ue, 0=false)

"Overload Count" ????? Run??? overload ?????.

"FFT Count" ????? Run??? FFT's ???.

"Logging Status" ??Data Logging ???1???? 0

"Last Logging Time" ????data logging?timestamp?????? N/A .

"Macro Status" ????????????: 0=stopped, 1=running. -1=utility is not open.

"Signal Generator Type Left" ????????????

"Signal Generator Type Right" ???????????

??

"Amplitude Axis Scaling Left" ??????????: 0=Linear, 1=Logarithmic

"Amplitude Axis Scaling Right" ??????????: 0=Linear, 1=Logarithmic

"Frequency Axis Scaling Left" ??????????: 0=Linear, 1=Logari thmic, 2=Octave

"Frequency Axis Scaling Right" ??????????: 0=Linear, 1=Logarithmic, 2=Octave

"Spectrum Weighting Left" ???????????: 0=Flat, 1=A, 2=B, 3=C

"Spectrum Weighting Right" ???????????: 0=Flat, 1=A, 2=B, 3=C

"Total Power Weighting Left" ????????????: 0=Flat, 1=A, 2=B, 3=C

"Total Power Weighting Right" ????????????: 0=Flat, 1=A, 2=B, 3=C

"PSD Left" ????? PSD ?? (0=off, 1=on)

"PSD Right" ????? PSD ?? (0=off, 1=on)

"PSD Type Left" ????? PSD ?? (0=units^2/Hz, 1=units/sqrt(Hz))

"PSD Type Right" ????? PSD ?? (0=units^2/Hz, 1=units/sqrt(Hz))

"Mic Compensation Left" ???????????? (0=off, 1=on)

"Mic Compensation Right" ???????????? (0=off, 1=on)

"Mic Compensation File Left" ????????????

"Mic Compensation File Right" ????????????

????

"Peak Frequency" ??????

"Peak1 Frequency" ?????????.

"Peak2 Frequency" ?????????.

"Peak3 Frequency" ?????????.

"Peak4 Frequency" ?????????.

"Peak5 Frequency" ?????????.

"Peak6 Frequency" ?????????.

"Marked Peak Frequency" ??? Marker1 ? Marker2 ??????

????: ?????????? ?? [Set Peak Search Bandwidth # &] ??

????

"Peak Amplitude" ??????

"Peak1 A mplitude" ????????.

"Peak2 Amplitude" ????????.

"Peak3 Amplitude" ????????.

"Peak4 Amplitude" ????????.

"Peak5 Amplitude" ????????.

"Peak6 Amplitude" ????????.

"Marked Peak Amplitude" ??? Marker1 ? Marker2??????

??????

"Marker1 Amplitude" ??Marker 1???

"Marker2 Amplitude" ??Marker 2 ???

"Marker3 Amplitude" ??Marker 3 ???

"Mar ke r4 Amplitude" ?? Marker 4 ???

"Marker5 Amplitude" ??Marker 5 ???

"Marker 6 Amplitude" ?? Marker 6 ???

"Marker7 Amplitude" ?? Marker 7 ???

"Marker8 Amplitude" ?? Marker 8 ???

???

"Total Power" ??????????

"Total Power A" ? A ???????

"Total Power B" ? B ???????

"Total Power C" ? C ???????

"Total Power Flat" ?????????

"Marked Total Power" ??????? Marker1 ? Marker2 ????????

"Marked Total Po wer A" ?A???? Ma rker1 ? Marker2 ????????

"Marked Total Power B" ? B ???? Marker1 ? Marker2 ????????

"Marked Total Power C" ? C ???? Marker1 ? Marker2 ????????

"Marked Total Power Flat" ????? Marker1 ? Marker2 ????????

????

"THD" ?? THD ?

"THD+N" ?? THD+N ?

"IMD" ?? IMD ?

"SNR" ?? SNR ?

"SINAD" ?? SINAD ?

"NF" ?? Noise Figure (NF) ?

"Delay Find er" ??delay finder ???delay ?.

"THD vs Frequency" ?? THD+N vs Frequency?? (????) **

"Compare Left THD vs Freq to Limits" '??*

"Compare Right THD vs Freq to Limits" '??*

* Return values for THD vs Freq Limit check:

-2 - ??????

-1 - ??THD ?

0 - THD ?????

1 - THD ?????

?????

"Leq Values" ???? Leq ?

"LeqT" ?? LeqT ?

"Leq" ?? Leq ?

"Lsel" ?? Lsel ?

"Lpk" ?? Lpk ?

"Lmax" ?? Lmax ?

"Lmin" ?? Lmin ?

"L10" ?? L10 ?

"L50" ?? L50 ?

"L90" ?? L90 ?

????

"Spectrum" ???????????**

"Spectrum Left" ????????????**

"Spectrum Right" ????????????**

"Zoomed Spectrum" ???????????zoom in/out ??**

"Zoomed Spectrum Left" ??????????????zoom in/out ??**

"Zoomed Spectrum Right" ??????????????zoom in/out ??**

"Marked Spectrum" ????????? Marker1? Marker2 ??????**

"Marked Spectrum Left" ???????????? Marker1? Marker2 ??????**

"Marked Spectrum Right" ???????????? Marker1? Marker2 ??????**

"Peak Hold Spectrum" ????????????????**

"Peak Hold Spectrum Left" ?????????????????**

"Peak Hold Spectrum Rig ht" ?????????????????**

"Zoomed Peak Hold Spectrum" ?????????????zoom in/out????**

"Zoomed Peak Hold Spectrum Left" ??????????????zoom in/out????**

"Zoomed Peak Hold Spectrum Right" ??????????????zoom in/out????**

"M arked Peak Hold Spectrum" ????????? Marker1? Ma rker2 ??????**

"Marked Peak Hold Spectr um L eft" ???????????? Marker1? Marker2 ??????**

"Marked Peak Hold Spectrum Right" ???????????? Marker1? Marker2 ??????**

???????

"Compare Left Spectrum To Overlay 1" ????????? Overlay 1. ? Markers 1 ? 2.???????

"Compare Left Spectrum To Overlay 2" ????????? Overlay2. ? Markers 3 ? 4.???????.

"Compare Left Spectru m To Overlay 3" ????????? Overlay 3. ? Markers 5 ? 6.???????.

"Compare Left Spectru m To Overlay 4" ????????? Overlay 4. ? Markers 7 ? 8.???????.

"Compare Left Peak H old To Overlay 1" ??????????? Overlay 1. ? Markers 1 ? 2.???????.

"Compare Left Peak Hold To Overlay 2" ??????????? Overla y 2. ? Markers 3 ? 4.???????.

"Compare Left Peak Hold To Overlay 3" ??????????? Overlay 3. ? Markers 5 ? 6.???????.

"Compare Left Peak Hold To Overlay 4" ??????????? Overlay 4. ? Markers 7 ? 8.???????.

"Compare Right Spectrum To Overlay 1" ????????? Overlay 1. ? Markers 1 ? 2.???????.

"Compare Right Spectrum To Overlay 2" ????????? Overlay 2. ? Markers 3 ?4.???????.

"Compare Right Spectru m To Overlay 3" ????????? Overlay 3. ? Markers 5 ? 6.???????.

"Compare Right Spectrum To Over lay 4" ????????? Overlay 4. ? Markers 7 ? 8.???????.

"Compare Right Peak Hold To Overlay 1" ??????????? Overlay 1. ? Markers 1 ? 2.???????.

"Compare Right Peak Hold To Overlay 2" ??????????? Overlay 2. ? Markers 3 ? 4.???????.

"Compare Right Peak Hold To Overlay 3" ??????????? Overlay 3. ? Markers 5 ? 6.???????.

"Compare Right Peak Hold To Overlay 4" ??????????? Overlay 4. ? Markers7 ? 8.???????.

* ?? "Compare Spectrum To" ???:

-2 = ?????

-1 = ????

0 = ?????????

1 = ?????????

2 = ???????

????

"Phase" ???????????**

"Phase Left" ????????????**

"Phase Right" ????????????**

"Zoomed Phase" ?????????????zoom in/ou??**

"Zoomed Phase Left" ??????????????zoom in/ou??**

"Zoomed Phase Right" ??????????????zoom in/ou??**

"Marked Phase" ????????Marker1 ? Marker2 ??????**

"Marked Phase Left" ???????????Marker1 ? Marker2 ??????**

"Marked Phase Right" ???????????Marker1 ? Marker2 ??????y**

????

"Time Series" ???????????**

"Time Series Left" ?????????????**

"Time Series Right" ?????????????**

"Zoomed Time Series" ??????????zoom in/ou??**

"Zoomed Time Series Left" ?????????????zoom in/ou**

"Zoomed Time Series Right" ?????????????zoom in/ous**

"Wave Segment" ? [Set Time Segment # ##] ????????**

" Wave Segment Left" ?[Set Time Segment # ##] ???????????**

"Wave Segment Right" ?[Set Time Segment # ##] ???????????**

"Wave Sample Left" ? [Go To Sample ##] ?????????????

"Wave Sample Right" ? [Go To Sample ##] ?????????????

** ????:

?????????????? clipboard{linkID=770}?????:

??

??? = Frequency in Hz

??? = Amplitude in same units as current display.

??

??? = Frequency in Hz

??? = Phase in degrees

??

??? = Time in seconds

??? = Amplitude in same units as current display.

???: Dynamic Data Exchange{linkID=1150}, DDE Commands,{linkID=1120} DDE Examples{linkID=1140}


DDE 笆篈计沮ユ传 ㄒ

DDE ?????? ??

Microsoft Excel 7.0 DDE Module Example:

(Limit testing - runs THD test and checks against spec.)

Sub LimitTest()

'Start a DDE connection with SpectraPLUS-SC- You should already have opened the program.

ch = DDEInitiate("Specplus", "Data")

DDEExecute ch, "[File Open c:\spectraplus\config\thd_test.cfg]"

DDEExecute ch, "[Run]"

'wait 10 seconds

newHour = Hour(Now())

newMinute = Minute(Now())

newSecond = Second(Now()) + 10

newTime = TimeSerial(newHour, newMinute, newSecond)

Application.Wait newTime

DDEExecute ch, "[Stop]"

'retrieve the results from the analyzer

Data = DDERequest(ch, "THD")

thd_value = Data(1)

'Check result against specification

If thd_value < 0.05 Then

MsgBox("Test PASSED")

Else

MsgBox("Test FAILED")

End If

DDETerminate ch

End Sub

Microsoft Excel 7.0 DDE Module Example:

(Statis tics - Acquires 20 sets of averaged 1/3 Octave data)

Sub ThirdOctaveTest()

'Start a DDE connection with SpectraPLUS-SC- You should already have opened the program.

ch = DDEInitiate("Specplus", "Data")

'Control variables. Change these as needed.

MaxAverages = 20

AverageTimeMinutes = 1

CurrentAverage = 0

Do

'Start the analyzer

DDEExecute ch, "[Run]"

'wait N minutes from now

newHour = Hour(Now())

newMinute = Minute(Now()) + AverageTimeMinutes

newSecond = Second(Now())

newTime = TimeSerial(newHour, newMinute, newSecond)

Application.Wait newTime

' Stop the analyzer

DDEExecute ch, "[Stop]"

'Request the spectrum data from the analyzer, it will be placed in an array.

DataArray = DDERequest(ch, "Spectrum")

'Find the total number of bands in the spectrum - we will have one row per band

num_bands = UBound(DataArray)

'Place the spectral data in the worksheet starting from right to left. 'Since two

'columns of numbers are sent to us (freq, amplitude) we will simply overwrite

'the frequency column with the next column of amplitude data.

'Statistical calculations can then be performed in Sheet1

Worksheets("Sheet1").Range(Cells(2, MaxAverages - CurrentAverage), Cells(1 + num_bands, MaxAverages - CurrentAverage + 1)).Formula = DataArray

CurrentAverage = CurrentAverage + 1

If CurrentAverage >= MaxAverages Then Exit Do

Loop

DDEExecute ch, "[Stop]"

DDETerminate ch

End Sub

See Also: Dynamic Data Exchange{linkID=1150}, DDE Comm ands{linkID=1120}, DDE Data Request Items{linkID=1130}


COM API

???????? Visual Basic, C++ or Excel. ???????????

Initializing the In terface

Control Functions{l inkID=1260}

Read Data Functions

???SpectraPLUS??????.


COM API - ﹍て

COM API - ???

Us ing Visual Basic{li nkTarget=VisualBasic}

Us ing Visual C++{li nkTarget=VisualC}

Ex cel{li nkTarget=Excel}

No te: ??? Automation Tools option (/10) ??????????????? "Accessed Denied" ??.

Vi sual Basic (Microsoft Visual Studio 2008)

1. Add a reference to the automation interface to your project

2. Create an instance of the class

3. Call the methods

Add the reference to your project:

1. Choose Project | Add Reference�

2. On the Add Reference dialog, choose the COM tab

3. Select the SpectraPLUS-SC Automation Typelib

4. Click OK

Dimension and Instantiate an instance of the SpectraPLUS-SC SC Automation Interface class object

Dim SP As SpectraPLUS-SC_SCAutomationLib.ISpectraPLUS-SC_SC

SP = New SpectraPLUS-SC_SCAutomationLib.SpectraPLUS-SC_SCClass

Call the methods in the interface as desired

SP.Run()

Return Values

The methods return HRESULTs, so Visual Basic will convert the return value to an exception if an error occurred. As such, you must handle exceptions in your code.

On Error GoTo Err_Trap

... call methods, etc.

Err_Trap:

Dim sMsg As String

sMsg = "The error returned: "

sMsg = sMsg & Err.Description

MsgBox sMsg, vbCritical, _

"Error" & Str$(Err.Number)

Err.Clear

Resume Next

Accessing Arrays

Below is a simple example of how to use the SAFEARRAYS with the GetSpectrum() call. Both freq and data are single precision floating point arrays.

Dim freq() As Single

Dim data() As Single

SP.GetSpectrum(0, freq, data)

Dim n As Variant

For Each n In freq

Value = n

Next n

For Each q In data

Value = q

Next q

Visual C++ (Visual Studio 2008)

1. Import the Type Library (TLB)

2. Create a smart pointer of that type

3. Call the methods

#import "C:\SpectraPLUS-SC_SC\bin\ SPAxnIface.tlb" no_namespace

CoInitialize(NULL);

ISpectraPLUS-SC_SCPtr ISP(__uuidof(SpectraPLUS-SC_SCClass));

if ( ISP )

{

ISP->Run();

}

� execute remainder of program �

ISP = 0;

The return values of the functions are HRESULTS. The Visual C++ implementation of smart pointers will intercept those return values and throw exceptions on errors. Thus, all code must be wrapped with try/catch blocks. The type of exception thrown is an _com_error.

try

{

ISP->Run();

}

catch ( _com_error &error )

{

MessageBox( error.ErrorMessage() );

}

Microsof t Excel

1. Enable the Devel oper tab in Excel

2. Add a reference to the automation interface

3. Create an instance of the class

4. Call the methods

Enable the Developer tab

Excel 2007

1. Click on the Office button

2. Click on Excel Options

3. Click Popular

4. Check the "Show Developer tab in the Ribbon" box

Excel 2010

1. Click on the File tab

2. Click the Options command

3. Click the Customize Ribbon category

4. In the Main Tabs list on the right, put a check in the "Developer" box

Add a reference to the automation interface

1. Click on the Developer tab

2. Click on View Code

3. Choose Tools | References

4. Scroll down and check the box next to the "SpectraPLUS-SC Automation Typelib"

5. Click OK

Dimension and Instantiate an instance of the SpectraPLUS-SC Automation Interface class object

Dim SP As SpectraPLUS-SC_SCClass

Set SP = CreateObject("SpectraPLUS-SC_SC.Axn")

Call the methods

SP.Run

Below is a simple example of how to read an array of spectral data and write it to the spreadsheet

Dim channel As Integer

Dim startHz As Single

Dim stopHz As Single

' define the frequency span and channel

channel = 0

startHz = 500#

stopHz = 2000#

' Arrays to contain the spectral data

Dim freq() As Single

Dim data() As Single

' Read the data from the analyzer

SP.GetSpectrumInSpan channel, startHz, stopHz, freq, data

Dim n As Variant

Dim q As Variant

Dim col As Integer

Dim row As Integer

' Load the data into the cells

col = 1

row = 1

For Each n In freq

Sheet1.Cells(row, col).value = n

row = row + 1

Next n

col = 2

row = 1

For Each q In data

Sheet1.Cells(row, col).value = q

row = row + 1

Next q


COM API - 北

COM API - ????

The following functions can be used to control the analzyer.

Function Groups

Anal yzer Operations{lin kTarget=AnalyzerOperations}

Anal yzer Configuration{lin kTarget=AnalyzerConfiguration}

Plot and Window Commands{lin kTarget=Plot Commands}

File Management{lin kTarget=FileManagement}

File Positioning{lin kTarget=FilePositioning}

File Post Processing{lin kTarget=FilePostProcessing}

Sign al Generation{lin kTarget=SignalGeneration}

{ta rget=AnalyzerOperations}Analyzer Operations

Run()

Description: Run the analyzer or start recording

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

Stop()

Description: Stop the analyzer, recording or playback.

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

Play()

Description: Play the file starting from the current position. You must be in the Recorder mode and a wave file must be open.

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

Record()

Description: Start recording. You must be in the Recorder mode.

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

RecordPause()

Description: Pause the current recording. The analyzer will continue running but data will not be stored in the wave file.

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

RecordResume()

Description: Resume a paused recording.

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

FileSte p( int numFFTSteps )

Description: Performs the specified number of FFTs starting at the current file position and advancing by the overlap setting (Post Processing mode only)

Parameters: numFFTSteps: 1 or more

Return: S_OK = success, E_FAIL = unsuccessful

Tri gger()

Description: Forces a single trigger event. Analyzer must be running and triggering must be enabled.

Return: S_OK = success, E_FAIL = unsuccessful

{ta rget=AnalyzerConfiguration}Analyzer Configuration

L oadConfig( BSTR cfg_filename )

Description: Load the specified configuration file. This is the quickest way to change all the analyzer settings.

Parameters: cfg_filename = filename of the configuration file. Full path or just filename if file located in /Config folder

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will look in the Config path as listed in the <File><Set Paths> dialog box.

SaveConfig( BSTR cfg_filename )

Description: Save the current settings to the specified configuration file

Parameters: cfg_filename = filename of the configuration file.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will store in the Config path as listed in the <File><Set Paths> dialog box.

Set Mode( long mode )

Description: Set the current mode

Parameters: mode: 0 = Real Time, 1 = Recorder, 2 = Post Processing

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Set NumChannels( long num_channels )

Description: Set the number of channels. This command will fail if a wave file is open and you attempt to change the number of channels.

Parameters: num_channels: 1 = mono, 2 = stereo

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etSamplingRate( long rate )

Description: Set the sampling rate for the device. This command will fail if a wave file is open and you attempt to change the sampling rate.

Parameters: rate = samples per second

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etSamplingPrecision( long bits )

Description: Set the sampling precision for the device. This command will fail if a wave file is open and you attempt to change the sampling precision.

Parameters: bits: 8, 16 or 24.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etFFTsize( long fft_size )

Description: Set the FFT size.

Parameters: fft_size = 32 through 1048576 pts in powers of 2.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etSmoothingWindow( long window )

Description: Set the Smoothing window

Parameters: window = values as shown below:

   BARTLETT       0

      BLACKMAN       1

      FLATTOP        2

      HAMMING        3

      HANNING        4

      KAISER         5

      PARZEN         6

      TRIANGULAR     7

      UNIFORM        8

   Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etAverageMode( long mode )

Description: Set the Averaging Mode

Parameters: mode: 0 = Free Run, 1 = Sound Level Meter

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etAverageType( long type )

Description: Set the Averaging Type

Parameters: type: 0 = Exponential, 1 = Linear, 2 = Vector

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etAverageSize( long size)

Description: Set the average size

Parameters: size = average size 1 - 10000 (free run mode), 0 = Off, 1 = Fast, 2 = Medium, 3 = Slow, 4 = Forever (SLM mode)

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ResetAverage( )

Description: Reset the running average

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetDualChannelProcessingMode( long proc_mode )

Description: Set the dual channel processing mode. This will fail if the analyzer is set to mono operation.

Parameters: proc_mode:

LEFT_ONLY                      0

RIGHT_ONLY                     1

BOTH_LEFT_AND_RIGHT            2

AVERAGE_LEFT_AND_RIGHT          3

RATIO_LEFT_AND_RIGHT      4

RATIO_RIGHT_AND_LEFT      5

CROSS_SPECTRUM_LEFT_AND_RIGHT       6

CROSS_SPECTRUM_RIGHT_AND_LEFT       7

TRANSFER_LEFT_AND_RIGHT             8

TRANSFER_RIGHT_AND_LEFT             9

COHERENCE_FUNCTION                  10

TRANSFER_L_R_AND_COHERENCE          11

TRANSFER_R_L_AND_COHERENCE          12

   Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Ena blePSD( long channel )

Description: Enable Power Spectral Density scaling

Parameters: channel: 0 = Left, 1 = Right.

Return: S_OK = success, E_FAIL = unsuccessful

D isablePSD( long channel )

Description: Disable Power Spectral Density scaling

Parameters: channel: 0 = Left, 1 = Right.

Return: S_OK = success, E_FAIL = unsuccessful

S etAmplitudeScaleType( long channel, long scale_type )

Description: Set the amplitude axis scaling type for the specified channel

Parameters: channel: 0 = Left, 1 = Right. scale_type: 0 = Linear, 1 = Logarithmic, 2 = Log Magnitude

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etFrequencyScaleType( long channel, long scale_type, long octave_number )

Description: Set the frequency axis scaling type for the specified channel

Parameters: channel: 0 = Left, 1 = Right.

octave_number: 1,3,6,9,12,24,48,96 (ignored if scale_type not Octave)

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etSpectrumWeighting( long channel, long weighting )

Description: Set the spectrum weighting for the specified channel

Parameters: channel: 0 = Left, 1 = Right.

weighting: 0 = Flat, 1 = A, 2 = B, 3 = C

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etTotalPowerWeighting( long channel, long weighting )

Description: Set the total power weighting for the specified channel

Parameters: channel: 0 = Left, 1 = Right.

weighting: 0 = Flat, 1 = A, 2 = B, 3 = C

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

T riggerEnable()

Description: Enable triggering

Return: S_OK = success, E_FAIL = unsuccessful

T riggerDisable()

Description: Disable triggering

Return: S_OK = success, E_FAIL = unsuccessful

S etTriggerThreshold( float threshold_pct )

Description: Set the trigger threshold value

Parameter: threshold_pct: the trigger threshold in percent between 0 and 100

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

S etPeakHold( long channel_ext, long peak_hold_type )

Description: Set the peak hold type for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

peak_hold_type: 0 = Off, 1 = Fast, 2 = Medium, 3 = Slow, 4 = Forever

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

ResetPeakHold( long channel_ext )

Description: Resets the peak hold values for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

SetOverlapPercentage( long overlap_percent )

Description: Sets the overlap percentage value

Parameters: overlap_percent = 1 - 99

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetCompensationFile( long channel, BSTR filename )

Description: Set the transducer compensation file for the specified channel

Parameters: channel: 0 = Left, 1 = Right. filename = mic compensation filename

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will look in the Mic comp path as listed in the <File><Set Paths> dialog box.

EnableCompensationFile( long channel )

Description: Enable the transducer compensation file for the specified channel

Parameters: channel: 0 = Left, 1 = Right

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

DisableCompensationFile( long channel )

Description: Disable the transducer compensation file for the specified channel

Parameters: channel: 0 = Left, 1 = Right

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetMarkerFreq( long channel_ext, long marker, float freqHz )

Description: Set the frequency for the specific channel and marker index

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

marker = 1 - 8, freqHz = frequency in Hz

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

ResetOverloadCount( )

Description: Reset the overload (clipping) count for all channels

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

DataLoggingEnable()

Description: Enable data logging

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

DataLoggingDisable()

Description: Disable data logging

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

SetDataLoggingFile( long channel, BSTR filename)

Description: Set the data logging output filename for the specified channel

Parameters: channel: 0 = Left, 1 = Right. filename = data log filename.

Return: S_OK = success, E_FAIL = unsuccessful

Note: If a short filename is used, it will be stored in the data logging path as listed in the <File><Set Paths> dialog box.

LoadCalibrationFile( long channel, BSTR filename )

Description: Load the calibration file for the specified channel

Parameters: channel: 0 = Left, 1 = Right; filename = the filename of the calibration file

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will be stored in the calibration path as listed in the <File><Set Paths> dialog box.

CalibrateToExternalSource( long channel, float source_level )

Description: Perform a calibration measurement on the specified channel

Parameters: channel: 0 = Left, 1 = Right; source_level = value to calibrate to (SPL example: 94.0).

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Notes:

You must be using the calibration option to calibrate to an external source.

The measurement will continue until the following conditions are met:

1) The measured signal level is stable to within +/-0.1 millivolt. This is approximately +/-0.03 dB with typical mic sensitivities.

2) The measured signal level is within 12% of its original value. This is approximately +/-1 dB.

If both of these conditions are not satisfied within 60 seconds the measurement will stop and an E_FAIL error will occur.

These conditions will assure that settling has completed, the mic calibrator is turned on and the correct mic and channel are used.

Sav eCalibrationFile( long channel, BSTR cal_filename )

Description: Save the calibration file for the specified channel

Parameters: channel: 0 = Left, 1 = Right; cal_filename = filename of the calibration file.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will store in the Cal path as listed in the <File><Set Paths> dialog box.

Set RunControl( long mode, long fft_limit, float time_limit, float start_delay_time )

Description: Set the Run Control options

Parameters: mode: 0=Continuous, 1=Stop after FFT limit, 2=Stop after time limit

fft_limit: number of FFTs to process before stopping when mode = 1

time_limit: seconds to process before stopping when mode = 2

start_delay_time: seconds to delay before starting processor

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

{ta rget=Plot Commands}Plot and Window Commands

Ope nPlot( long channel, long plot_type )

Description: Opens a plot for the specified channel

Parameters: channel: 0 = Left, 1 = Right.

plot_type: 1 = Time Series, 2 = Spectrum, 3 = Phase, 4 = Spectrogram, 5 = 3-D Surface

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Clo sePlot( long channel, long plot_type )

Description: Closes a plot for the specified channel

Parameters: channel: 0 = Left, 1 = Right.

plot_type: 1 = Time Series, 2 = Spectrum, 3 = Phase, 4 = Spectrogram, 5 = 3-D Surface

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Min imizeApplication( )

Description: Minimize the overall application window to an icon

Return: S_OK = success, E_FAIL = unsuccessful

Max imizeApplication( )

Description: Maximize the overall application window on the screen

Return: S_OK = success, E_FAIL = unsuccessful

R estoreApplication( )

Description: Restore the application to it's previous size

Return: S_OK = success, E_FAIL = unsuccessful

H ideApplication( )

Description: Hide the overall application window and icon.

Return: S_OK = success, E_FAIL = unsuccessful

S howApplication( )

Description: Show the overall application window and icon (restore from HideApplication())

Return: S_OK = success, E_FAIL = unsuccessful

ClearSpectrum( lo ng channel_ext )

Description: Clears the spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

ClearPeakHoldSpectrum( lo ng channel_ext )

Description: Clears the peak hold spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

SetSpectrumPlotFrequencySpan( lo ng channel_ext, float startHz, float stopHz )

Description: Set the displayed frequency span for the spectrum plot for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

startHz = start frequency, stopHz = stop frequency

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

SetSpectrumPlotTop( lo ng channel_ext, float plot_top )

Description: Set the display amplitude plot top parameter for the spectrum plot for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

plot_top = plot top value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

SetSpectrumPlotRange( lo ng channel_ext, float plot_range )

Description: Set the display amplitude plot range parameter for the spectrum plot for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

plot_range = plot range value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

SetSpectrumPlotGraphType( lo ng channel_ext, long graph_type )

Description: Set the spectrum plot graph type for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

graph_type: 0 = Line, 1= Bars, 2 = Stepped Bars

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

{target=FileManagement}File Management

FileOpen( BSTR wav_filename)

Description: Open a wave file

Parameters: wav_filename = wave filename

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will look in the Wave path as listed in the <File><Set Paths> dialog box.

FileSave( BSTR wav_filename)

Description: Save the wave file.

Parameters: wav_filename = wave filename

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will store in the Wave path as listed in the <File><Set Paths> dialog box.

FileClose( )

Description: Close the wave file

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

{ta rget=FilePositioning}File Positioning

FileRewind( )

Description: Go to the start of the wave file

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileForward( )

Description: Go to the end of the wave file

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileGoToTime( floa t seconds)

Description: Go to a specific time in the wave file

Parameters: seconds = file position in seconds

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileGoToSample( unsi gned long sample)

Description: Go to a sample position in the wave file

Parameters: sample = file position in samples

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

{ta rget=FilePostProcessing}File Post Processing

FilePlaySegmentTime( float start_seconds, float stop_seconds)

Description: Playback the specified time segment

Parameters: start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FilePlaySegmentSample( u nsigned long start_sample, unsigned long stop_sample)

Description: Playback the specified time segment

Parameters: start_sample = segment start sample position; stop_sample = segment stop sample position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileFilterSegmentTime( float start_seconds, float stop_seconds)

Description: Filter the specified time segment

Parameters: start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileFilterSegmentSample( unsigned long start_sample, unsigned long stop_sample)

Description: Filter the specified time segment

Parameters: start_sample = segment start sample position; stop_sample = segment stop sample position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileProcessSegmentTime( f loat start_seconds, float stop_seconds)

Description: Computes the average spectral data for the specified time segment (same as right clicking on time series plot and choosing "Compute Average Spectrum")

Parameters: start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileProcessSegmentSample( unsigned long start_sample, unsigned long stop_sample)

Description: Computes the average spectral data for the specified time segment (same as right clicking on time series plot and choosing "Compute Average Spectrum")

Parameters: start_sample = segment start sample position; stop_sample = segment stop sample position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileCutTime( float start_seconds, float stop_seconds)

Description: Cut the specified time segment and place it on the clipboard

Parameters: start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Fil eCutSamples( long start_sample, long stop_sample)

Description: Cut the specified time segment and place it on the clipboard

Parameters: start_sample = segment start position; stop_sample = segment stop position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Fil eCopyTime( float start_seconds, float stop_seconds)

Description: Copy the specified time segment and place it on the clipboard

Parameters: start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Fil eCopySamples( long start_sample, long stop_sample)

Description: Copy the specified time segment and place it on the clipboard

Parameters: start_sample = segment start position; stop_sample = segment stop position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Fil ePasteTime( float paste_position_seconds)

Description: Paste the current clipboard contents (wave data) into the current file at the specified position

Parameters: paste_position_seconds = location to paste the data

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Fil ePasteSamples( long paste_position_sample)

Description: Paste the current clipboard contents (wave data) into the current file at the specified position

Parameters: paste_position_sample = location to paste the data

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Fil eMuteTime( float start_seconds, float stop_seconds)

Description: Mute the specified time segment

Parameters: start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Fil eMuteSamples( long start_sample, long stop_sample)

Description: Mute the specified time segment

Parameters: start_sample = segment start position; stop_sample = segment stop position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Set FilterChannel( long channel )

Description: Set the filter channel

Parameters: channel: 0 = Left only, 1 = Right only, 2 = Both Left and Right

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Set FilterFile( BSTR filter_filename )

Description: Set the filter filename

Parameters: filter_filename = filename of filter file

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will look in the Filter file path as listed in the <File><Set Paths> dialog box.

{ta rget=SignalGeneration}Signal Generation

OpenGenerator()

Description: Open the signal generator utility

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

CloseGenerator()

Description: Close the signal generator utility

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

RunGenerator()

Description: Start the signal generator

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

StopGenerator()

Description: Stop the signal generator

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

Set GeneratorSignalType( long channel_sig, long signal_type )

Description: Set the signal type for the specified signal generator channel

Parameters: channel = 0 - 1; signal_type - as follows:

0 = White Noise

1 = Pink Noise

2 = Noise Burst

3 = 1 kHz Tone

4 = Multiple Tones

5 = Tone Burst

6 = IMD Tones

7 = Freq Sweep

8 = Level Sweep

9 = Sawtooth

10 = Triangular

11 = Pulse

12 = Squarewave

13 = User Defined wave file

14 = DTMF

16 = Digital Zero

16 = Frequency Step

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetGeneratorLevel( long channel_sig, float levelDBr )

Description: Set the output level for the specified signal generator channel

Parameters: channel = 0 - 1; level = signal level in dBr (0 = max, -96 = min).

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetGeneratorFreq( long channel_sig, float freqHz )

Description: Set the signal type to Multiple tones and enable only a single tone at the specified frequency. The multitone level is set to 0 dBr (use SetGeneratorLeve() to set the output level)

Parameters: channel = 0 - 1; freqHz = frequency in Hz

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: The signal type will change to Multiple Tones when this command is used.


COM API - 弄计沮

COM API - ??????

Functions used to read data and status from the analyzer:

Genera l Status{linkT arget=GeneralStatus}

Peak S earch Operations{linkT arget=PeakSearch}

Distor tion Readings{linkT arget=DistortionReadings}

Total Power Readings{linkT arget=TotalPower}

Marker Readings{linkT arget=MarkerReadings}

Conver sion Operations{linkT arget=ConversionOperations}

Time S eries Data{linkT arget=TimeSeriesData}

Spectr al Data{linkT arget=SpectralData}

Phase Data{linkT arget=PhaseData}

Leq Da ta{linkT arget=LeqData}

{targ et=GeneralStatus}General Status

IsRunning ( int *runStatus )

Description: Determine if the analyzer is currently running, or recording

Parameters: runStatus = pointer to receive the analyzer run status (0 = stopped, 1 = running or recording)

Return: S_OK = success, E_FAIL

GetCurrentFileTime( float *seconds )

Description: Get the current (position) time in the file

Parameters: seconds = pointer to variable to receive the time value in seconds

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTo talFileTime( float *seconds )

Description: Get the total time in the file

Parameters: seconds = pointer to variable to receive the time value in seconds

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetCu rrentFileSample( unsigned long *sample )

Description: Get the current sample position in the file

Parameters: sample =pointer to variable to receive the sample position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTo talFileSamples( unsigned long *samples )

Description: Get the total number of samples in the file

Parameters: samples = pointer to variable to receive the total samples value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetFF TCount( long *fftcount )

Description: Get the number of FFTs that have been performed since run or record were last pressed

Parameters: fftcount - pointer to variable to receive the the fft count

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetOv erloadCount( long channel, long *overloadcount )

Description: Get the number of Overload conditions (clipping) that have been detected since run or record were last pressed

Parameters: channel ; 0 = Left, 1 = Right; overloadcount - pointer to variable to receive the the overload count

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

{targ et=PeakSearch}Peak Search Operations

Get PeakFrequency( long channel_ext, float *freq )

Description: Get the peak frequency in the total span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

freq = pointer to variable to receive the peak frequency

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

GetPe akFrequencyNth( long channel_ext, long peak_number, float *freq )

Description: Get the Nth peak frequency in the total span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

peak_number = 0 - 10; freq = pointer to variable to receive the peak frequency

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

GetPe akFrequencyNthSpan( long channel_ext, long peak_number, float startHz, float stopHz, float *freq )

Description: Get the Nth peak frequency in the specified span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

peak_number = 0 - 10; startHz = span start frequency; stopHz = span stop frequency;

freq = pointer to variable to receive the peak frequency

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

GetPe akAmplitude( long channel_ext, float *amplitude )

Description: Get the peak amplitude in the total span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

amplitude = pointer to variable to receive the peak amplitude

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

GetPe akAmplitudeNth( long channel_ext, long peak_number, float *amplitude )

Description: Get the amplitude of the Nth peak in the total span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

peak_number = 0 - 10; amplitude = pointer to variable to receive the peak amplitude

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

GetPe akAmplitudeNthSpan( long channel_ext, long peak_number, float startHz, float stopHz, float *amplitude )

Description: Get the amplitude of the Nth peak in the specified span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

peak_number = 0 - 10; startHz = span start frequency; stopHz = span stop frequency;

amplitude = pointer to variable to receive the peak amplitude

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

{target=TotalPower}Total Power Readings

Get TotalPower( long channel_ext, long weighting, float *power )

Description: Get the total power in the total span for the specified channel and weighting

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

weighting: 0 = Flat, 1 = A, 2 = B, 3 = C

power = pointer to variable to receive the total power value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

GetTo talPowerSpan( long channel_ext, long weighting, float startHz, float stopHz, float *power )

Description: Get the total power for the specified frequency span for the specified channel and weighting

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

weighting: 0 = Flat, 1 = A, 2 = B, 3 = C

startHz = span start frequency; stopHz = span stop frequency;

power = pointer to variable to receive the total power

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

{targ et=DistortionReadings}Distortion Readings

Get THD( long channel_ext, float *thd )

Description: Get the THD over the total span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

thd = pointer to variable to receive the THD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get THDSpan( long channel_ext, float startHz, float stopHz, float *thd )

Description: Get the THD over the specified frequency span and channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

startHz = span start frequency; stopHz = span stop frequency;

thd = pointer to variable to receive the THD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get THD_N( long channel_ext, float *thd_n )

Description: Get the THD+N over the total span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

thd_n = pointer to variable to receive the THD+N value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get THD_NSpan( long channel_ext, float startHz, float stopHz, float *thd_n )

Description: Get the THD+N over the specified frequency span and channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

startHz = span start frequency; stopHz = span stop frequency;

thd_n = pointer to variable to receive the THD+N value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get IMD( long channel_ext, float *imd )

Description: Get the IMD over the total span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

imd = pointer to variable to receive the IMD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get SNR( long channel_ext, float *snr )

Description: Get the SNR over the total span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

snr = pointer to variable to receive the SNR value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get SNRSpan( long channel_ext, float startHz, float stopHz, float *snr )

Description: Get the SNR over the specified frequency span and channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

startHz = span start frequency; stopHz = span stop frequency;

snr = pointer to variable to receive the SNR value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get SINAD( long channel_ext, float *sinad )

Description: Get the SINAD over the total span for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

sinad = pointer to variable to receive the SINAD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get SINADSpan( long channel_ext, float startHz, float stopHz, float *sinad )

Description: Get the SINAD over the specified frequency span and channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

startHz = span start frequency; stopHz = span stop frequency;

sinad = pointer to variable to receive the SINAD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

{target=MarkerReadings}Marker Readings

Get MarkerFrequency( long channel_ext, long marker, float *freq )

Description: Get the frequency at the specified marker

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

marker = 1 - 8;

freq = pointer to variable to receive the frequency value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get MarkerAmplitude( long channel_ext, long marker, float *amplitude )

Description: Get the amplitude at the specified marker

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

marker = 1 - 8;

amplitude = pointer to variable to receive the amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

{targ et=ConversionOperations}Conversion Operations

Con vertTimeToSample( float time_seconds, unsigned long *sample )

Description: Convert from seconds to sample position

Parameters: time_seconds = time value to convert

sample = pointer to variable to receive the sample position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Con vertSampleToTime( unsigned long sample, float *time_seconds )

Description: Convert from sample position to time

Parameters: sample = sample position to convert

time_seconds = pointer to variable to receive the time in seconds

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

{target=TimeSeriesData}Time Series Data

Get TimeSeriesValueFromTime( long channel, float time_seconds, float *value )

Description: Get the time series amplitude value a the specified time

Parameters: channel: 0 = Left, 1 = Right, 2

value = pointer to variable to receive the time series amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Get TimeSeriesValueFromSample( long channel, unsigned long sample, float *value )

Description: Get the time series value a the specified sample position

Parameters: channel: 0 = Left, 1 = Right, 2

value = pointer to variable to receive the time series amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Get MaxTimeSeriesValueInSegment( long channel, unsigned long startSample, unsigned long stopSample, float *value )

Description: Get the maximum time series value in the specified time segment

Parameters: channel: 0 = Left, 1 = Right, 2

startSample = time segment start position in samples;

stopSample = time segment stop position in samples;

value = pointer to variable to receive the maximum time series amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Get MinTimeSeriesValueInSegment( long channel, unsigned long startSample, unsigned long stopSample, float *value )

Description: Get the minimum time series value in the specified time segment

Parameters: channel: 0 = Left, 1 = Right, 2

startSample = time segment start position in samples;

stopSample = time segment stop position in samples;

value = pointer to variable to receive the minimum time series amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Get TimeSeriesFromFile( long channel, SAFEARRAY __RPC_FAR * __RPC_FAR *psaTimes, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of time series data for the specified channel

Parameters: channel: 0 = Left, 1 = Right, 2

psaTimes = pointer to array of time values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Get TimeSeriesFromFileSegmentSample( long channel, unsigned long startSample, unsigned long stopSample, SAFEARRAY __RPC_FAR * __RPC_FAR *psaTimes, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of time series data for the specified time segement and channel

Parameters: channel: 0 = Left, 1 = Right, 2

startSample = start sample of time series segment;

stopSample = stop sample of time series segment;

psTimes = pointer to array of time values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Get TimeSeriesFromFileSegmentTime( long channel, float startSecs, float stopSecs, SAFEARRAY __RPC_FAR * __RPC_FAR *psaTimes, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of time series data for the specified time segement and channel

Parameters: channel: 0 = Left, 1 = Right, 2

startSecs = start time of time series segment;

stopSecs = stop time of time series segment;

psaTimes = pointer to array of time values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

{target=SpectralData}Spectral Data

Get SpectrumMinFrequency( long channel_ext, float *freq )

Description: Get the minimum available frequency in the spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

freq = pointer to variable to receive the frequency value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get SpectrumMaxFrequency( long channel_ext, float *freq )

Description: Get the maximum available frequency in the spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

freq = pointer to variable to receive the frequency value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get SpectrumValue( long channel_ext, float freqHz, float *value )

Description: Get the amplitude value of the spectral data at the specified frequency and channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

freqHz = frequency to read the amplitude

value = pointer to variable to receive the amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get Spectrum( long channel_ext,SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get SpectrumInSpan( long channel_ext, float startHz, float stopHz, SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

startHz = start frequency of selected span;

stopHz = stop frequency of selected span;

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get PeakHoldSpectrumValue( long channel_ext, float freqHz, float *value )

Description: Get the peak hold amplitude value of the spectral data at the specified frequency and channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

freqHz = frequency to read the amplitude

value = pointer to variable to receive the amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get PeakHoldSpectrum( long channel_ext,SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of peak hold spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get PeakHoldSpectrumInSpan( long channel_ext, float startHz, float stopHz, SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of peak hold spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

startHz = start frequency of selected span;

stopHz = stop frequency of selected span;

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

G etComplexSpectrum( long channel_ext,SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaDataR, SAFEARRAY __RPC_FAR * __RPC_FAR *psaDataI )

Description: Get an array of complex spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

psaFrequencies = pointer to array of frequency values

psaDataR = pointer to array of real component of complex values

psaDataI = pointer to array of imaginary component of complex values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get ComplexSpectrumInSpan( long channel_ext, float startHz, float stopHz, SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaDataR, SAFEARRAY __RPC_FAR * __RPC_FAR *psaDataI)

Description: Get an array of complex spectral data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

startHz = start frequency of selected span;

stopHz = stop frequency of selected span;

psaFrequencies = pointer to array of frequency values

psaDataR = pointer to array of real component of complex values

psaDataI = pointer to array of imaginary component of complex values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

{target=PhaseData}Phase Data

Get PhaseValue( long channel_ext, float freqHz, float *value )

Description: Get the phase value at the specified frequency and channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

freqHz = frequency to read the phase

value = pointer to variable to receive the phase value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get Phase( long channel_ext,SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of phase data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of phase values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

Get PhaseInSpan( long channel_ext, float startHz, float stopHz, SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of phase data for the specified channel

Parameters: channel_ext: 0 = Left, 1 = Right, 2 = Composite, 3 = Coherence.

startHz = start frequency of selected span;

stopHz = stop frequency of selected span;

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of phase values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: Composite channel = dual channel operation (L&R average, Transfer Function or Cross Spectrum)

{target=LeqData}Leq Data

Get LeqValues( long channel, float *LeqT, float *Leq, float *Lsel, float *Lpk, float *Lmax, float *Lmin, float *L10, float* L50, float *L90 )

Description: Get the Leq (Equivalent Noise Level) values for the specified channel

Parameters: channel: 0 = Left, 1 = Right

LeqT = pointer to the equivalent noise level converted to the user specified "reference time period".

Leq = pointer to the equivalent noise level for the selected time segment.

Lsel = pointer to the equivalent noise level converted to a 1 second period.

Lpk = pointer to the peak level for the selected time segment. No averaging is used for this parameter.

Lmax = pointer to the maximum level for the selected data.

Lmin = pointer to the minimum level for the selected data.

L10 = pointer to the level exceeded 10% of the time.

L50 = pointer to the level exceeded 50% of the time.

L90 = pointer to the level exceeded 90% of the time.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter


┦闽拜肈

Processing Speed

???????????????? FFT siz e. ????????? FFT{linkID=420} ?????????????????.

???????????????????????????video subsystem???????? Spectrum ???????

3-D Surface{linkID=180} ? Spectrogram{linkID=160} ???????????????????????????????????????????????????????????

??:

???? Time Series plot ????????? FFT ????????????d

???: FFT size, Settings


秖代非絋

?????

?????Frequency Accuracy:

???????????????????? ????????Hertz (Hz).??????????????????.

????Amplitude Accuracy:

?????????? 8, 16 ? 24 bit ???????0 dB????????????? calibrat e?????????????????????? (???????????????????)????????? mic compensation . ??????????????????????????(????????) ??????????????????????? ??<Edit> <Copy>. ??????????????????????(?????????????????0dB????

???/ ????????Octave Scaling Accuracy:

,????????????? ???????? (ANSI S1.11-2004) ??????? ?? SpectraPLUS-SC ???? Fast Fou rier Transfor m (FFT) ????????????/ ???????????????ISO???????????FFT ????????????? "shoulders".????????????????.

????Dynamic Range:

???????????:

8 bit sampling precision = 48 dB

16 bit sampling precision = 96 dB

24 bit sampling precision = 144 dB

????????????????.

??:

??????????????????Automatic Gain Control (AGC). ????????????.

???: Scaling, Settings , Calibration{linkID=750}


睼舼

??

????????????1/2???? sampling rate.{lin kID=190} ????????????????????????????????????3500Hz ????6000Hz ????????????????????2500???

????????????????????????????????????????????? Settings ????? "Apply Low Pass Filter when Decimating"???

???: Sampling Rate, Measurement Accur acy{linkI D=800} , Decimation Ratio , File Decimate


е倍龄

???

????? toolbar{linkID=940} ??????????????????????????????<Alt>??????????????

?????????????????????????<Alt>+?????????????<Alt> + <V> ???<Alt>??<T> ????????

???????"???" ?????????????????:

???:

F1 Help

F4 Processing Settings tabbed dialog box

F5 Plot Options tabbed dialog box

F6 Trigger dia log box

F7 Save Configuration File

F8 Load Configuration File

F10 Data Logging Setup

F11 Signal Generator Utility

Ctrl+0 File Open

Ctrl+S File Save

Ctrl+A File Save As

Ctrl+P File Print

Alt+F4 Exit SpectraPLUS-SC

Ctrl+Z Undo last edit

Ctrl+Del Edit Cut

Ctrl+Ins Edit Copy

Shift+Ins Edit Paste Insert

Ctrl+L Play Special - Loop

Shift+F5 Window Cascade

Shift+F4 Window Tile Vertical

Shift+F3 Window Tile Horizontal

????????:

??????post-processing???? return key? (+) ? in the post-processing mode will ??????????????? (??????). ????????????

????? (-) ???????????? overlap percent ?????????

????????"foc us"???????????

.

Focus ?????:

??????scrollbars????2???????"focus "?????????????????????????????????????????Average ??????????????up/down??????????

???: Toolbar,{linkID=940} Status bar{linkID=910}


ㄤㄣ

?????

SpectraPLUS-SC ?????????????????:

Main Application Tool bar

Secondary Toolbar {li nkID=945}

Individual View Toolb ars

???: Basic Operation,{linkID=3 60} Keyboard Sho rtcuts{linkID=240} , Cursor Mea surements{linkI D=870}


篈逆

???

???????????????????????:

Run status (??, ??? ).

Operating Mode{linkID=30}

Sam pling Format{li nkID=200}.

FFT size{linkID=290}

Smoothi ng window{linkID=280}

??:

??????? sampling rate,{li nkID=19 0} FFT size,{lin kID=290} ? smo othing window{linkID=2 80} ?????????????????( ?WAV???????????sampling rate cannot be changed when a WAV file has been opened).

  • ?????????????????? settings{linkID=240} ???.


м砃や穿

????

??????????.

????????????????????????????????Windows ????????????????????????????????. ?? "README.TXT"?????? .

Mail: Pioneer Hill Software LLC, 24460 Mason Rd NW, Poulsbo WA 98370 USA

Voice: 360 697-3472

Fax: 360-824-6031

Email: pioneer@spectraplus.com

Website: www.spectraplus.com

Copyright 1993-2013, PHS

All Rights Reserved.

Legal Notices and Trademark attributions.

All trademarks are the property of their respective owners.


ず羘厩臫莱

???????

????????????????????????????????????????:

????:

Mode: Real-Time

Views: Spectrum, Ti me Series

Amplitude axis: Logarithmic

Frequency axis: 1/3 Octave

Standard Weighting: Flat

Mic compensation: Yes, if your mic is not sufficiently "flat"

Sampling rate: 44100Hz

FFT size: 8192 or 16384.

Decimation: 1

Averaging size: infinite

Smoothing Window: Uniform

Sampling Format: 16 bit, Mono

????:

??????????0 ? ????.

????????????????.

?????????????.

  • ???????????????? / ?????????????????? "on-scale"???? .
  • ????????????????????????????
  • ????:
  • ???????? "flat" ????????????????????????????? ????????????????1/3 octave???????????1/3 octave????? ??????????????????????????????.
  • ?????? (??):
  • 1/3 oc tave??????????????????????????????????1/3 octave ????????????????????????? ??????????????????????(??????FFT size??1024)


羆坑猧ア痷だ猂

???????

?????????????????????????????? Total Harmonic Distortion (THD) ?????????.

THD ?????????????????????THD ??????????"??" "cleaner" ???? THD ????1kHz ????????????????????THD ?

????:

Mode: Real-Time

Views: Spectrum, Time Series

Amplitude axis: Logarithmic

Frequency axis: Linear

Standard Weighting: Flat

Mic compensation: None

Sampling rate: 44100Hz

FFT size: 8192

Decimation: 1

Averaging size: 10

Smoothing Window: Hanning

Sampling Format: 16 bit, Mono

????:

???? 1kHz ??????????? .

????????????.

????????????????.

?<Utilities> ?????? <Total Harmonic Distortio n> .


锣传ㄧ计

????

??????????????????????.

?????????????????????????????????????????????????????????????? t.

?????????????????????????;.

????:

Mode: Real-Time

Views: Spectrum, Phase

Sampling Rate: At least twice the highest frequenc y produced by the device under test

FFT size: 4096 typical

Averaging: 4

Peak Hold: Off

Smoothing Window: Hanning

Dual Channel Spectral Processing: Real Transfer Function Left/Right"

Sampling Format: 16 bit Stereo

Frequency scaling: your choice

Amplitude scaling: Logarithmic

Spectral Weighting: flat

????:

??????????????.

????????????????? .

????????????????.

???????????????????.

??:

??????????????????????.


к秖代

????

????????????????????????????????????????????1 ?1k ohm ?1?10 ohma ????2.

????????????? .

Step 1 - 10 Ohm ??????

??????1?1 0 Ohm ???.

???????? "1 k Hz tone"

??? Cal ibration - ?????????

?? "Measure Reference Signal"??

??? Calibration - ?????????

?? "Measure Reference Signal"??

?? Ok ??????????.

Step 2 - ??????Validate the calibration

(?? 10 Ohm ??)

???????? "White Noise"

????? - ????? 10 Ohm ?????????????? 0 ?.

Step 3 - ???????

?????????????10 Ohm ???

?????

????????????

?????????????

???????:

Missing image: im pedancetest_settings.bmp

???? - ???:

Missing image: impedancete st_scaling.bmp

???? - ???:

{bmc ImpedanceTest_CalLeft.bmp}

???? - ???:

Missing image: im pedancetest_calright.bmp


粂だ猂

????

??????????????????? ???????????????????"time-frequency"????????????.

????:

Mode: Recorder/Post-Processing

Views: S pectrogram, Spectrum

Sampling rate: 22050 Hz

FFT size: 512 or 1024

FFT overlap percentage: As detailed below.

Decimation: 1

Smoothing window: Hamming

Averaging size: 2 or 3

Amplitude Scaling: Logarithmic

Frequency Scaling: Linear

Sampling Fromat: 16 bit mono.

Mic Compensation: As required.

Spectral weighting: Flat

????:

??????????.

???????.

?????????? 0 .

???? rewind ???????????.

  • ???????????????????.
  • ???????????????????play ???????????.
  • ????????????????????.
  • ???????????????????.
  • ???????? 90%
  • ????????????.
  • ???????????/ ??????????????????????????.
  • ?????????????????????. (???????????????????)
  • ?????????????????????????????????????????????????????????.
  • ??:
  • ???3-D ??????????????.


诀瘪綺笆だ猂

??????

??????????????????????????????????????????????????????????????.

????:

Mode Recorder/Post-Processing

Views 3-D surface, Spec trum

Sa mp ling rate 11050 Hz

FFT size depends on test length (15 min. test use 32k)

FFT overlap percentage As detailed below.

Decimation 15 for low frequency vibration < 60 Hz

Smoothing window Hanning

Averaging size 20

Amplitude Scaling Logarithmic

Frequency Scaling Linear

Sampling Precision 16 bit mono

Input Accelerometer

????:

????

???????????????????????????????????.

????.

???????? .

??????????? 50%.

  • ???????????????.
  • ??????? 3-D ???????????.
  • ????????????????????????????????.
  • ?????????????????.
  • ????????????????????????????.
  • ??:
  • ????????????????.


3-D 陪ボ贺匡兜

3-D ?????????

3-D ?????????? Options | Plot Options 3-D Surface Display ???????????view toolbar.??????? 3-D Surfa ce ??????

Frequency Spa n: ??? "Ful l Span"???????????????,?? "Custom Span"???????????? .

Display Update Interval: ???????FFT?????????????????????N ????????????? Real-Time ???????????????????- ?????.

Plot Top/Range: Plot Top ? Range?????????? Plot Top?????????? ?????? T op value ???? Range ????????? linear scaling ?? Plot Range ?????0 ?????? .

Co lo rs: ??????????????????? "Default"???????????????Multicolor Gradient ???????????????????color bar ???????/ ????????????? ????????????? "Custom Color" ????????????????

Show Toolbar: ???????????

Notes:

????????? (??????) ???3-D ??????????? (?? Escape ?????).

????View ??????Clear ??????.

???: 3-D Surface View


侥猧

???

???????????? ?? "Details" ?????????????????????"????" "One Shot Pulse" ??????????????????????" Run" ????????????.

???: Signal Generator, Squarewave


ㄣ凝

??????

Missing image: face="ms sans serif" size="2">l selectup.bmp ????: ?????????????????????????????????????????????? (playback, filtering, cut/copy/p aste){link ID=770} ??.

Missing image: slp layup.bmp ????: ?????????? <Edit><Play>{linkID=760} ??????????.

{bml SLFIL TUP.BMP} ????: Filt er . ?????????<Edit><Filter> ??????????

Missing image: zoomup.b mp ????: ???????????????????????? ???????? / ??????????????????????????.

Missing image: z2inu p.bmp ????Zoom In 2 X: ???????????????.

????Zoom Out 2X: ???????????????.

???????Zoom Out Full: ???????/ ?????.

Missing image: opti onup.bmp ??????: ?????????????????<Options><Spectrum> ????????.

{bml GLINEUP.BMP} ?????: ???????????.

Missing image: gstbarup.bmp ?????: ???????????.

Missing image: gbar up.bmp ?????: ???????????.

Missing image: a utoscal.bmp ??????: ????????? Plot Top/Range ??????? .

??: ??????? (????)

????: ?????????. ?????????????? up/down????????.

????: ?????????????????????????? ??? up/d own????????????????????.

????: ????????? peak hold{li nkID=260} (???spectrum ??)

: Main Toolbar


繵笵ユ岿┑筐

???????

???? Cross-Spect rum,???? Coherence Funct ion ?? ????? Complex Transfer Funct ion ????????? ??????????????????????????????????????? ? Delay Finder Utiltity ?????????????

??????????????? (1/S ampling Rate). ??????? up/down ??????????????

??:

?????????????.

???: Delay F inder{linkID=660}, Settings{linkID=240}, Dual Channel Processing Options{linkID=23 0}


へ夹

?????

???/????Octave??????????????????????????????????????????????????CPB????????????????????????????????? 1/1?1/3??????????? - ??1/3 Octave??????

?????????????????????????????????????????????????????????????????????????????????????????????CPB?????????????????????????3dB?????????????????

SpectraPLUS-SC.?????????????????????

????????????????????????? SpectraPLUS-SC ??????????FFT FFT ???????(??)?????????????????/ ???????????????/ ?????

?????FFT??????????????/ ???????????FFT ??????/ ??????????????1/3 ???/ ???????????FFT???1/3?????????

FFT?? 1/3 ?????

32 3

64 6

128 10

256 13

512 16

1024 19

2048 22

4096 25

8192 28

16384 31

32768 34

65536 36

?????????? sampling rate ? decimation ratio. ??

???: Scaling, FFT size


ヘ魁

??

??

Wel come{lin kID=1110}

What is a spectrum analyzerlinkID=20}

Sys tem Requirements{lin kID=900}

??

Basic Operation{linkI D=30}

Setti ng up the analyzer{linkI D=880}

Curso r measurements{linkI D=870}

Right Mouse Click Actions{linkI D=860}

Printing the results{linkID=810}

????

Working w ith Audio Files

Importing Files

Exporting Files

File Opti ons

File Deci mate

File Merge

Set Paths

Configuration Files

??

Cut/C opy/Pa ste

Play/Play S pecial

Filtering{l inkID=780}

Mute{linkID=1180}

Gain Adjust

DC Offset{linkID=1190}

Select All{linkID=1170}

??

Real-Ti me{lin kID=40}

Post-Processi ng

Recorder{link ID=60}

??

Time Seri es{lin kID=80}

Spectrum{linkID=130}

Phase{linkID=10 0}

Spectrogram{lin kID=160}

3-D Surface{lin kID=180}

??

Settings{li nkID=2 40}

Scaling{linkID=36 0}

Markers{linkID=38 0}

Triggering{linkID=400}

Calibration{linkI D=750}

Run Control{linkID=435}

Devices{linkID=410}

????

Signal Gene rator{link ID=620}

Save Signal to WAV file{linkID=440}

Peak Frequency{linkID=730}

Peak Amplitude{linkID=720}

Total Power{linkID=710}

Total Harmonic Distortion (THD){linkID=740}

Total Harmonic Distor tion + Noise (THD+N){linkID=740}

Total Harmonic Distor tion + Noise (THD+N) versus Frequency{linkID=745}

InterModulation Disto rtion (IMD){linkID=700}

Signal to Noise Ratio (SNR){linkID=690}

Signal to Noise Plus Distortion (SINAD){linkID=680}

Noise Figure (NF){linkID=670})

Delay Finder{linkID=6 60}

Stereo Phase Scope{li nkID=947}

Reverberation Time{li nkID=650}

Equivalent Noise Leve ls{linkID=865}

??

Status and Author izatio n{linkID=1100}

???

Data Logging{linkI D=430}

Macro Command Processor{li nkID=640}

Dynamic Data Exchange (DDE) - Overview{linkID=1150})

DDE Commands{linkID=1120}

DDE Data Request Items{lin kID=1130}

COM API - Overview {linkID=1240}

COM API - Initialization{l inkID=1250}

COM API - Control Function s{linkID=1260}

COM API - Read Data Functi ons{linkID=1270}

??????

Processing Speed{linkID=1230}

Measurement Accuracy{linkID=800}

Aliasing{linkID=790}

????

Key board Sho rtcuts{linkID=370}

Too lbars{linkID=940}

Status bar{li nkID=910}

Application Notes{link ID=1030}

Tec hnical Support{lin kID=950}


碩禸へ夹

??????

??????????????????????:

Linear value = 10 ^ (Log value/20)

Log value = 20 * Log10 (Linear value)

Linear ??????????????????????????????????????????????????????????????

Logarithmic ????????????????????????????????t.

Log Magnitude ???????????????.


繵瞯禸へ夹

??????

??????????????: ???????/ ????? ????????????????;???/ ??????????????

?????

?FFT{?linkID=420}????????????????????????????????????????????????????????????????? sampling rate?FFT??FFT size ?????

???/ ?????

???/ ???????????????????????/ ????????? 1/1?1/3?????????????????? Octave Sc aling{linkID=320}

???: Amplitude Axis Scaling{linkI D=330}, Scaling{link ID=360}


秖代莱ノ

??????

??????????????????????????????????????????????????????????????????????????????????? .

Peak Frequency

Peak Amplitude

Total Power

Total H armonic Distort ion (THD){linkID=740}

Total Harmonic Distortion + Noise (THD+N{linkID=740}

THD+N vs Frequency{linkID=745}

In terModulation Distortion (IMD

Signal to Noise Ratio (SNR{linkID=690}

Signal to Noise and Distortion (SINAD)

Noise Figure (NF){linkID=670}

??:

????????????? spectrum view.????


禬秖盎代

????

??overload????????????????????????????????? "clipping"???? ???????????????.

?????????????????????????????????????????????????.

???????????????????????????????????.

???????????????????????????????????????????

???; Settings{linkID=240}, Calibration


ㄣ

????

???????? Mode.{linkID =30} ??? ????????????????? (Run/Stop etc)??????? Real-Time ???? Post-Processi ng{linkID=50} ??????? averagin g block size{li nkID=270} ? peak hold{linkI D=260} ???????? ???????????Settings{linkID=24 0} ?????????.

???? Recorder ???? Post- Processi ng ???????????? .WAV???????????????????????????.

Real-Time{l inkID=40}

Run ?????

Stop ?????

Avg ?? averaging block size

Recorder{linkID=360}

Rec ????

Stop ??

Fwd ????????

Rwd ???????

Play ???????

Scroll ????????.

Post-Process{linkID=60}

Run ?????

Stop ?????

Rwd ????????

Avg ???????? averaging block size

Scroll ????????

Load Configuration - ????

??:

???????????? settings{linkID=240} ???.

??? : View Toolbars{linkID=920}


繵眯陪ボ匡兜

??????

??????????? Options | Plot Options ??????????? Spectrum tab ???????? view toolbar{linkID=920}.????

Plo t Type: ??? ??????????????????????????????????????????????? FFT sizes? ???????????? Octave ??????????????

Plot Top/Range: Plot T op ? Range ????????????? Plot Top???????? ??????????Range ????????? linear scaling{linkID=360} ?? Plot Range ???? 0???????

Peak Hold: ???? Peak Hold ???????????????? ??????????? Peak Hold .

Pull Cursor to Tr ace: ?????????? measurement cursor{linkID=870} ????????????????

Show Toolbar: ??????????.

Show Overlay Controls: ????????????? overlay controls??over lay contr ols ???? + ? - ???????????

Colors: ??????????????????? default ??????????.

Marker Options: ?? markers{linkID=380}.?????????????? "Mrk" ??????.

Grid Lines: ???????.

Frequency Span: ??????? toolbar,{linkID=310} ??zoom ???????? ????????????? ???????????????????????????????????????????????.

Display Update Interval: ???????????????????????????????????

Show Total Power Meter: ????t otal po wer meter ??????????? "Total"?????????????????? (?? Scaling ??????). ???????? + ? - ???????????

Show Zoomed Power Level: ????????????? RMS ???????????????????????????????????????????????????????????

???: Spectrum View{linkID=130}, View Toolbar{linkID=920}


舼

??

????????????????????????????? .

??????????????????????????????????6?????????????"Composite"????????.

??: ??????????????/ ????????????

???????

??????????????????????????????????? "On". "Off" ???/ ???????.

?? "Options" ???????????????:

?

L egend: ?????24????????????????????????????????????????????????? .

Offset: ?????????????????????????????.

Disk Storage: ???/ ???????????????????????????????. L1.OVL, L2.OVL, L 3.OVL, L 4.OVL, L5.OVL, L6.OVL, R1.OVL, R2.OVL, R3.OVL, R4.OVL, R5.OVL and R6.OVL. ???????????????????????????????????

Trace Colors: ??????????????????????????????????????????????????????????.

Legend Display Size: ?????????????????????????????24???.

??????:

???????????????????ASCII ??? ???????(Tab) ???????????????????????????????????????????????????????????????????????????????3 ~ 32768 bit?

??????????( cubic spline algorithm) ????? ??????? microphone compensation ??????.

?????

????"C" ?????????"??"???????????6???????????????????????????????????????????????????.

??: ??????????????????????????????? Set Paths ?????????/ ?????????????????? .MIC or .OVL ?????

????: ?????????????????????????????????????????????????

;SPLINE OFF

??????????????.


丁陪ボ贺匡兜

???????????

????????????????? Options | Plot Options ???????? Time Series ????? view toolbar{linkID=920}.???????

Plot Type: If Am plitude (linear) ???????????????????,(?????????). ??? Energy (logarithmic) ???????????? Decibels with 0 dB ?? 100% ?????????????? calibration ??????

Plot Top/Center/Range: ??????????????????????? amplitude (linear) ?? P lot Top val ue ??????, Center ??????? Plot Range ?????????? Energy (logarithmic) ?? Plot Top ???????? ??????????? Range??. The Center value ??????????.

Channel Selection: ???????????????????????????/ ?????? X/Y ?????? Mono ?? ( Settings),{linkID=240} ???????????????.

Colors: ??????????????????? default ??????????.

Grid Lines: ?????????.

Show Toolbar: ??????????????????.

Pull Cursor to Trace: ????????? measurement cursor{linkID=870} ???????????????.

Display Update Interval: ??????????????????????????????????? .

???: Time Series View{linkID=80}


蛮繵笵矪瞶贺匡兜

??????????

???????????????????????

???????????????????????????????????????????????????????????????????????????Real Time ?????????????????????? <File><Merge> ??.?????????????? ??

????????

??????????????????????????????????????????????? Scaling ??? Calibra tion {linkID=750}???????????????.

?????????????????????? ????????????????G????????????? ? 1/3 octave ???????.

???????? :

Left Channel Only - ?????????? auto-spectr um (magn itude).

Right Chan nel Only - ?????????? auto-spectrum (magnitude).

Both Left and Right - ?????????? auto-spectrum (magnitude) ???????????????.

Average Left and Right - ?????? the auto-spectrum ????.

Real Transfe r Function - ??????????????????

  • Cross Spectrum - ??????????????.
  • Complex Transfer Function - ????????????????.
  • Coherence Function - ??????????????.
  • ??:
  • ??????????????? time series view{linkID=80}.?
  • ???????????????????????????????????? Cross Channel Delay{linkID=220} ????????????????
  • ??
  • ????Auto-spectrum - ???????????????(??)?????????????????????????????????? spectrum view{link ID=130}?.
  • ????Cross-spectrum - ???????????????????????? ?????????(??????????) . ???????????????????? ????????????????? ????????180�??????????????????0? ?????????????????????????

????/ ????Transf er Function -???????????????????:

?????? -????????????????? ???????????????????.

?????? - ????????????????????????????????????????.

??????????????????????????????dev ice under test.???????? "Tr ansfer Functions{linkID=990}" ??????.

????Coherence Function -???????????????????????????????????????????????? ?????????????????1.0 (0 dB).

???: Cross Channel Delay{linkID=220}, Settings{linkID=240}, Sampling Format{linkID=200}


フ靖

???

???????????????????????????????narrowband ??????????

?????????????????

???: Signal Generator, Pink Noise


靖

????

????????????????????????????????????/ ?????3dB?????????? octave???????????????????????????????????.

???: White Noise, Signal Generator


1kHz 虫癟腹

1 1kHz ????

1,000.0 Hz ???????????? distortion{linkI D=740} ???.

???: Signal Gener ator{li nkI D=620}, Multiple Tones{linkID= 530}, IMD tone s


癟腹

????

???????????????????????????10????????????????????????????

??????????????????????????????????????????.

????????????

?????????????????????????? decibels (dB).

???: Signal Generator, 1 kHz Tone, IMD Tones


陪ボ匡兜

??????

????????? ??? Options | Plot Options ??????? and Phase ????????????? view toolbar.???????

Pl ot Top/Range: Plot Top ? Range ????????????? Plot Top ?????????????????? Range ?????.

Colors: ??????????????????? default ??????????.

Pull Cursor to Trace: ????????? measurement cursor ???????????????.

Show Toolbar: ???????????

Grid Lines: ????????.

Frequency Span: ????? toolbar,{l inkID=310} ?zoom buttons ???????????????????????????????????????????????????????????????????????.

Display Update Interval: ???????????????????????????????????

???: Phase View


眯盞

????

??????PSD ???????1 Hz ????????????????????PSD?????????????????FFT????????????PSD?????????????FFT?????????.

??? Units / Sqrt(Hz)? Units^2/Hz???????????. Units^2/Hz

?PSD ??????????????????????????

??: PSD ????????????????( ??)??????.

???: Scaling


苯繵

?? (????)

????????????????????????????????????????????????????????????

????????????????????????????.

Jump Back to Start Frequency - ????????????????????.

Sweep Back to Start Frequency - ????????????????????.

Stop After a Single Sweep - ???????????????????????????????????.

Sweep Time - ???????????????????(ms). .

Sweep??????????????? averaging block size{linkID=270} ?1? ?????? Peak Hold ?????????????????????FFT ?? FFT size ??????????

??size ? FFT ????????????????????????????? .

???: Level Step{linkID=515}, Signal Generator


亏睛猧

???

?????????????????????"Details" ?? ?????????????????????????????????/ ???????

???: Signal Generator


à猧

???

????????????????? ?????"Details" ?? ????????????????????????

???: Signal Generator


よ猧癟腹

????

??????? ??????????????? "Details"????????????????/ ??? (duty cycle) ???????????????????/ ??? (duty cycle)??????????????????

???: Signal Generator, Pulse waveform


ㄏノ﹚竡猧

????????

????????????????WAV????????????????????????????"Pick "?????WAV????????????????????????????RAM?

SpectraPLUS-SC a?????????ASCII ????????????. ??? <File><Import> ????.

???: Save Signal to .WAV file, Signal Generator{linkID=620}


癟腹玻ネ竟块非

?????????

??????? signal generator? "Level" ???????????????????

????????????????????????????????????? "full scale" ???????8 bit, 16 bit, ?24 bit ?????100% ?????????????????????????????????????????? "full scale" ?????????? ".

????????????????????????????????dB ???????????

???????????????????????????????????0 dB????1 K Hz ????????????Volt RMS .

???????????????????????????????????????????????.

??:

?????????????????????????????????6 dB ?????????????clipping???.


苯磞猧

???

??????????????????????????????????????? ????????????????????????????

????????????????????????ms ?????????????????????.

???: Frequency Sweep, Signal Generator


が秸ア痷代刚

IMD ???????�

????InterModulation Distortion (IMD{linkID=700}) ????????????????????????? 12dB (4:1 ratio)?????????????????????????

???: Signal Generator{linkID=620}, Multiple Tones{linkID=530}, IMD{li nkID=700}


ㄏノ惠

????

Aco ustic response of a room{lin kID=970}

Voi ce analysis{lin kID=1010}

Tra nsfer Functions{lin kID=990}

Tot al Harmonic Distortion (THD){lin kID=980}

Imp edance Measurements{lin kID=1000}

Machine Vibration Analysis{linkID=1020}


繵猧琿

�????

?????????? (20 to 20,000 Hz)


砞﹚―キА

???????

??????????????????

?????

Free Run (bloc ks) - ??????????FFT ???????????????????????????????????????????????????????? 4 ????????????4????????.

???????????????????????????????????????????????????.

??????????????????????????????????????????????????? main toolbarS?????????????.

Sound Level Meter (SLM) - ????????????Sound Level Meter (SLM)????????????????????????????????????

Off - ????????.

Fast - ?32 dB/sec????????????

Medium - ?32 dB/sec ????????????

Slow - ?4 dB/se????????????.

Forever - ??????????????.

???Sound Level Meter???????????? .

????????

Exponential - ?????????????????????????????????????????????????????????????Sound Level Meter[???????????.

  • Linear - ?????????????????????????????????????????????" ????"
  • Vector - ?????????????????(??)?????????????????????????????????????????????" ?????"? .
  • ???????????.
  • ??:
  • ? Real-Time{linkID=40} ? Post-Processing ???????? toolbar.{linkID=940}m????"Av g"???????? / ?????

???: Peak Hold


蹦妓瞯

�????

????Decimation??????????????? ????????????????????? sampling rate???????????????????????????????????11025 Hz?????10 ???????1102.5 Hz??????0?551.25 Hz ??????.

????1?????????????

??????????????????????8:1 ????????????8?????7???? .

??????????????????Nyquist frequency ???????????????????????????? "Apply Low Pass Filter when Decimating"???

??:

?????????????????????????FFT FFT size,{linkID=290} ????? ??????????

?????????????????.

???: Sampling rate, FFT size


计0

??0

?????????0 ?????.


DTMF蛮繵

DTMF????

??????????(???)????????(DTMF) , ????????????( twist)???????.

?? twist???? dB. ??????????????????????????????????

???????DTMF full extended DTMF-(1234567890*#ABCD).

???: Right Click Action Menus


FFTе硉撑ミ腑锣传

FFT???????

FFT ???????? Fast Fourier Transform ????.

????????????? Jean Baptiste Fourier (1768 - 1830)????????????????????? (??-?-??) ??? (??-?-??)??????????????? .

??????? (FFT) ??? J.W. Cooley and J.W. Tukey ? 1965 ????????????????? ???????????????2?????

??? FFT????????????????(?)????????????????????????????????????


FFT 跋遏

FFT ?????

??FFT FFT{lin kID=420} ??????????????????????FFT???1/2 . ?????1024?FFT??512?????

???????????? ???Sampling Rate ?FFT?????? ??????FFT???1024?????8 192????????????

1024??8192= 8???

???FFT?????????????????????????

??:

??????????????????????????? Sampling Rate, FFT ????, Decimation ratio ???.

??FFT???????????? ????e sta tus bar

???: Sampling Rate , Decimation Ratio{linkID=250}


˙繵

?? (???? )

??(????) ?????????????????????????????????????????????????????????

?????????????????????(???/ ????).

????Linear Steps - ?Hz ?????????????????????????.

?????Octave Steps - ????????????????????/ ???????????.

Jump Back to Start Frequency - ????????????????????.

Sweep Back t o Start Frequency - ????????????????????..

Stop After a Single Pass - ?????????????????????????????????????????.

????Dwell Time - ??????????????????????????(ms) ????.

Stepped ??(??) ?????????????????????? averaging block size{linkID=270} ? 1 ??????? Peak Hold{linkID=260} ????????????????????.

???: Freq Sweep, Signal Generator{link ID=620}


材顶ㄣ

??????

?????????????????????? .

Buttons

Missing image: fnewup.bm p File Ne w - ??????? WAV ??????????

File Open - ??????? WAV ?

Missing image: fsaveup.b mp File S ave - ???? WAV ?

Missing image: pr intup.bmp Print - Print {li nkID=810}the active plot (time series, sp ectrum, phase, spectrogram, or 3-D surface)

Time Series View - ??/?? time series{linkID=80} ?

Missing image: specup.bmp Spectr um View - ??/?? spectrum ?

Missing image: phaseup.bm p Phase View - ??/?? phas e {linkI D=100}?

{bml GRAMUP.BMP} Spectrogr am View - ??/?? spectro gram {linkID=160}?

3-D Surface View - ??/?? 3-D Su rface{linkID=180} ?

{bml SETTINUP.BMP} FF T Settings - ?? FFT settings ???

Missing image: face="arial" size="2">l scaleu p.bmp Scaling - ?? Scaling {linkID=360}???

Missing image: c alup.bmp Calibration - ?? Calibration {l inkID=7 50}???

Missing image: t rigup.bmp Triggering - ?? Triggering ???

Missing image: runopts up.bmp Run Control - ?? Run Control{li nkID=435} ???

{bml DEVUP.B MP} I/O Device - ?? Device Settings{linkID=410} ???

Missing image: face="arial" size="2"> genup.bmp Signal Generator - ??/?? signal gener ator{linkID=620} ?????

Missing image: pkfrequp.bmp Hz - ??/?? Peak Frequency{linkID=730} ??

Missing image: pkampup.bmp dB - ??/?? Peak Amplitude{linkID=720} ??

Missing image: pwrup.bm p Pwr - ??/?? Wideband Level (total power) ??

{bml TH DUP.BMP} THD - ??/?? Total Harmonic Distortion ??

THD+N - ??/?? Total Harmonic Distortion + Noise{linkID=740} ??

Missing image: thdfrqup.bm p THD+N vs Freq - ??/?? THD+N vs Frequency{linkID=745} ??

IMD - ??/?? InterModulation Disto rtion{linkID=700} ??

SNR - ??/?? S ignal to Nois e Ratio ??

Missing image: face="arial" size="2"> lequp.b mp Leq - ??/?? Equ ival ent Noise Le vel (Leq) ??

Missing image: mac roup.bmp Mac - ??/?? Mac ro C ommand Proce ssor ??

Missing image: logu p.bmp Log - ??/?? Data L oggi ng {linkID=430}??

Missing image: delayu p.bmp Dly - ??/?? Delay Finder{linkID=660} ??

{bml REVERBUP.BMP} Rvb - ??/?? Rever beration Time {linkID=650} ??

Missing image: face="ms sans serif" size="2">l phas cpup.bmp Sc p - ??/?? Ste reo Phase Scope{linkID=947}

??: ???? <V iew><Toolbar s><Secondary Toolbar> ?????????.


沉干纕

??????

????????????????????????(???????????????)??????????????????????????????????????.

?????????????????????????????????????????????????????????????????????????.

???????????????:

?? NOTEPAD.EXE ?????????? word processor ????? ASCII ???.

??2 ????????????.

????????? Hertz.

???????? (???????).

?????????

? tab ????????

??:

---------------------------

100.0 -10.0

500.0 -5.0

1000.0 0.0

2000.0 2.0

10000.0 -5.0

15000.0 -15.0

?????????? 32,768 ?????3 ????????????? cubic spline?????????????????.

??????????????????

?????????????? .MIC. ?????

??:

?????????? Overlay????????????????????????????????????????????????????????????

???: ?????????????????????cubic spline interpolation algorithm ????????????????

;SPLINE OFF

????????

???: Standard Frequency Weighting


玃祇靖

????�

???????????????? ????"Burst Time" ??????????????? "Cycle Time" ??????????????????1000 msec???????? 2000 msec?????????????????????????????????????????????

???: Pink Noise, White Noise, Generator Output Level


舼κだゑ

?????

????Spectrogr am ?3-D ??? 3-D Surface{l inkID=180} ???????????????????????????????????????????FFT ?? FFT size???????????? (90+%) ????????????????????????????????????????? Post-Processing{linkID=50} ??????

?? FFT ??????????????????????FFT????????????????????????????: ?????????????????????????????????????????????FFT ???????????????????????FFT ???????????FFT ??????????????????????? ??????????????,

????????? FFT's ???4?????????????4?????.

?????????????????????????????3-D ???????????????????????????, ??? "Compute and Display Spectrogram".???????Action ??????????????????????????????? Right Click Action Menu ?????.

??:

????????????????.

???: Right Click Action Menus{linkID=860}, FFT size , Smoothing Windows,


畃玂痙

????

??????? Peak Hold ?????????????????????????????????????? Fast,???Medium ??? Slow?????????????????????????????????????????????????????. main toolbar ????????????.

? Spectrum display options ???????? toolbar.?????????

See also: Averaging Settings{linkID=270}


妓Α

????

?????????????????????????????bit ??????????????????????? / ?? (A/D)????????????????????????????? :

8 bit ?????? = 48 dB

16 bit ?????? = 96 dB

24 bit ?????? = 144 dB

????????????????????????????????????????????????? .

?????? "Mono"?????????????????????????? 1/8" stereo connector. ????????????????, .

?????? "Stereo" ????????? "dual channel processing options{linkID=230}" ???????????????????????????..

???: FFT size , Scaling, Measurement Accuracy


妓瞯

???

SpectraPLUS-SC ????????????????????????0? ????1/2 ?? decimation ratio.{linkID=250}

???Sampling Rate ?????????????????????????????? 10,000 Hz ????.0001 ??????????????????????

????????????? "Nyquist Sampling Theorem" ???????????????????2 ?????????????3000 Hz ???????????6000 Hz?????????????????3000 Hz ??????????? Aliasing ?

????? .WAV ???????? Format ???????????????????????????????- ??????.WAV ???????????.WAV ??????????????????????????????????? status bar{linkI D=910} ???

??:

????????????????????????????OK???????????????????????????????l.

???: Aliasing, FFT size , Decimation ratio


キ絯て怠 ㄧ计

????�??

???????0 ??????????????FFTs??????????????????????. ??????????????0????????????????????????????????????????????????????FFT ?????????????????????????????"??" ???????????????????.

?????????????????????????????????????????????????????????????????????????????.

????????????????????????0 ???????????????????????????? "smoothing window" ???????????????????????????????????????????????????????????????.

????????????????0 ?????????????????????????sidebands??????side lobes??????????????????????????????????????????????????????????????????????????????????????????????.

???????????????????? Uniform window ???????????

Missing image: s mooth.bmp

??????????????

??? ?? ?? ??

?? ?? ??? ?? ??

Bartlett Fair Fair Moderate

Blackman Fair Good Excellent ????

Flattop Poor Excellent Moderate ??????

Hamming Fair Fair Fair

Hanning Fair Excellent Excellent ?????????

Kaiser Fair Fair Poor

Parzen Fair Fair Poor

Triangular Fair Fair Poor

Uniform Excellent Poor Poor ???????????????

Gaussian Excellent* Fair Fair ???????????? *

*??????????????????????????? .

N??otes:

?????????????????.

?????????????????.

???: Scaling,{linkID=360} FFT size,{l inkID=290} Overlap Processing{l in kID=390} , Sampling Rate{linkID=190}


繵眯瓜陪ボ贺匡兜

??????????

????Options | Plot Optons ????????view t oolbar?????Spectrogram ????????????????.

Frequency Span: ? ? "Full Span" ??????????????????,"Custom Span"???????????????????????"Custom Span" ????????

Display Update Interval: ???????FFT?????????????????????N ????????????? Real-Time{linkID=40} ???????????????????- ?????.

Color: ???????????? "Color" ????????????????? "Grayscale" ????????????? "Custom" ?????????????????

Scroll Direction: ?????????????????.

Scroll Type: ?????????????????????????????????????????.

Plot Top/Range: Plot Top ? Range ???????(color bar)?? Plot Top ?color bar????. color bar????? Top value ??Range ?????????? linear scaling, Plot Range ????0??????

Show Toolbar: ???????????

??:

????????? (??????) ?????????????? (?? Escape ?????).

????View ??????Clear ??????.

???: Spectrogram View{linkID=160}


夹非繵瞯舦

???????

AN SI??? A, B ? C ????????????? / ???????????????????????????? total power bar?????????????????????500~10,000 Hz ????????????????? T

???: Scaling, Microphone Compensation , Octave


丁浪跌

??????

?????????????????????????????????????????

?????????????????60???????????????? Recorder{linkID=60} ??????? Post-Processing?????????????????????????????????????(?????)????????????????????????????????????????????.

Toolbar Controls

Time Series Display Options

Cursor Measurements

Right Click Action Menus

???: Performance Issues{li nkID=1230}


玃祇虫癟腹

??????

??????????????????"Burst Time" ?????????????? "Cycle Time" ??????????????????1000 msec???????? 2000 msec????????????????????????????????????????????.

???: 1kHz Tone, Multiple Tones, Generator Output Level